6

When I fullscreen an iTerm2 window, an empty line appears at the bottom of the terminal window. How do I get rid of it?

Compare these two screenshots:

Windowed (appears as expected) Windowed (appears as expected)

Fullscreen (empty line appears at bottom) Fullscreen (empty line appears at bottom)

I had enabled the Use Lion-style Fullscreen windows setting,

iTerm > Preferences > General > Window > Use Lion-style Fullscreen windows

so I tried disabling it. That appeared to resolve the problem--fullscreening a window after disabling this feature looked good, no extra line. But then after I switched applications using Command-Tab a few times, the extra line suddenly appeared. What's happening?!

Is this a bug? How do I prevent this from happening?


Solution: The accepted answer helped me to get rid of the extra line. I changed the font size in my iTerm2 profile settings to 16pt Monaco from 18pt Monaco. Here is a screenshot:

No extra line after switching font size

2
  • 1
    See askubuntu.com/q/687885/398785
    – egmont
    Feb 15 '16 at 17:48
  • 1
    @egmont - great! That solved my problem. Would you like to answer below with a quote from your link? I will upvote and accept your answer. That would help people find this solution who (like me) may at first assume it's an issue with iTerm2, rather than with terminal emulators generally.
    – Stew
    Feb 15 '16 at 18:13
4

See this answer, excerpted below. It was written about gnome-terminal, but it's the same for iTerm:

Terminal emulators work with a grid of cells: a whole number of cells both horizontally and vertically. That's why when you resize the window by dragging its corner, it resizes in unusually large steps rather than pixels. [...]

In fullscreen mode, gnome-terminal is forced to a size that's not a multiple of the size of its character cells. Utilities and applications running inside terminals have no notion of such partial cells and couldn't draw in the remaining area, it just doesn't exist for them.

You might want to experiment with different font sizes, you might find one where an integer number of cells just fit (or at least the gap is not that large)

5

Change the vertical character spacing in iTerm2 Fonts preferences and it should do the trick

7
  • 1
    Actually, this is an answer to the question.  The problem is that it's already been given.
    – Scott
    Jan 17 '17 at 4:36
  • @Scott This answer has not already been given, unless the other was deleted. Changing the font size is not the same as changing the vertical spacing. The former will affect character width, the latter will not.
    – 8bittree
    Jan 20 '17 at 17:57
  • @8bittree: Oh?  I don't use Mac, so I didn't know that they were different.  In that case, this answer should probably be more detailed, so that even a dummy (like me) can understand it and how to use it.
    – Scott
    Jan 20 '17 at 19:48
  • @Scott It's not a Mac specific thing, more of an application specific thing. Visually, it's basically equivalent to adjusting the line spacing in apps like Outlook or Word.
    – 8bittree
    Jan 20 '17 at 19:59
  • 1
    @Scott To my knowledge, iTerm is Mac specific. I was (and thought you were) referring to the ability to adjust vertical character spacing as not being a Mac specific concept.
    – 8bittree
    Jan 20 '17 at 20:30
1

Change the font size will do the trick. My monitor is 1920 x 1080, I set the font size to 15 and fixed the issue, btw I use the Meslo Nerd Font Mono.

You should try the different font sizes to find out the correct one.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.