1

I have a problem with my ASUS laptop (Windows 7 x64 Home Premium), where whenever I try to start any program (cmd.exe, explorer.exe, and various tools in control panel still work, but any 3rd party .exe files, iexplore.exe, MS Office apps - don't) - it crashes instantly with the following error message:

The application was unable to start correctly (0xc0000005). Click OK to close the application.

That error code, as far as I know, stands for STATUS_ACCESS_VIOLATION. And the problem started after windows update on (2016-Feb-10).

I am posting here as a last resort, since no matter how I tried to resolve this issue - it didn't work. The only remaining action would be complete reinstall, and I am trying to avoid that if possible.


What I tried:

  • Running sfc /scannow command in command prompt, since I've read that it might fix corrupted windows files. It found everything to be in order.
  • Running memtest (3 passes), since I've read that it might be an issue related to RAM failing. I doubted that it would find something, since the issues were related to non-essential, for Windows execution, applications, and I wasn't getting any BSODs. It didn't find any issues either.
  • Then, I thought that there may be some kind of virus infecting the computer. So, I created a Live Rescue USB stick with antivirus scanner on it, and booted the laptop from it, and ran full hard drive, In-Depth scan. No infected files detected.
  • Then, I thought that there may be issues with hard drive itself. So I ran chkdsk C: /F /R. No issues.
  • Then, I wanted to check S.M.A.R.T records of the hard drive, to see if it is failing. I downloaded a portable app which can check that. And then I realized that I can't run it, since it crashes, on startup like any other app. Then, I boot to safe mode, where, apparently, everything works fine, and applications don't crash on startup. But still, no issues reported in S.M.A.R.T records.
  • Then I tried to use tools such as Process Monitor to figure out what is happening before the applications crash. It had the same problem as any other application.
  • Then I tried to run System Restore to restore to a point before those updates. After doing the restore, and a reboot of a laptop, it said that it wasn't able to complete the process to to the error code 0x80070005 which stands for General access denied error, so it is more or less the same as the original error.
  • I started googling again, and found this article. But, since my Windows boot loader path doesn't contain xOsload.exe, but rather winload.efi, I assumed that it wouldn't help in my case.
  • Then, I saw this post. And, seeing that it is 2.5 years old, I didn't put much hope into it. I was right, after uninstalling the update in question, nothing changed.

So, I will be waiting on tips on how to solve this problem, without full reinstall (since that is, truly, the last resort). Thank you in advance.

  • What happens if you use a rescue disk to run one of the problematic programs from the computer's hard drive? I still suspect malware. – Ben N Feb 13 '16 at 17:14
  • @BenN Well that rescue disc is an "ESET Live Rescue" installed on USB stick, which contains a Linux based OS. So, when booting from it, it doesn't boot to Windows, so I can't run any Windows .exe files from there. I can just scan those partitions. In addition, I could run several of programs just fine from the safe mode, while they would refuse to launch from regular boot. – Algirdas Preidžius Feb 13 '16 at 19:01
  • When did this start? After a recent windows update? – Moab Feb 13 '16 at 19:08
  • @Moab Yes, it start after a windows update couple days back. – Algirdas Preidžius Feb 13 '16 at 19:11
  • 1
    @Moab I, then, found this tutorial on how to create bootable USB stick, but even then, when booting into it, and choosing repair option, it said that version of Windows on this USB, was mismatched to the one that is on my laptop. It was then, when I realized that I could still run the system recovery from the safe mode. And after that, I managed to pinpoint the problematic updates, which were: KB3126587, KB3126593. – Algirdas Preidžius Feb 14 '16 at 16:52
1

Had the exact same issues after the february 9 security updates hit my x64 Windows 7. Managed to narrow the issue down to update 3126587, just deleted it from command prompt and I'm no longer getting the xc0000005's.

So in command prompt, just enter: wusa.exe /uninstall /kb:3126587

You could also delete the update using windows updater in safe mode, the updater wouldn't show the list of installed updates for me in normal mode.

Hope that helps!

  • well, at first, after following your answer, and removing the update, you mentioned, I still had this problem. So, I proceeded on installing the updates one by one, to figure out which one was, really, the issue, since it seemed that the one that was a problem for you, wasn't for me. And it turned out, that there was not one, but two updates that were causing the issue. One of them being the one you mentioned, and the other being KB3126593. – Algirdas Preidžius Feb 14 '16 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.