3

everyone.

I'm new here, and somewhat a noob when it comes to Linux, but here's my situation. A friend had gotten an HP netbook (11-d020) with a 32GB eMMC. Even after getting a 32GB SD for additional storage, she's still frustrated with her space filling up. I'm trying to put Linux Mint 17.3 Cinnamon instead of Windows to clear up some space (Mint is the first that came to mind as an easy switch for her).

Well, I've installed Linux onto other machines no problem, but this one has me stumped. First, as I go into setting up the disks, the text Error fsyncing/closing /dev/mmcblk0rpmb: Input/output error appears. Clicking "Retry" doesn't get me anywhere, so I click "Ignore."

While working on the partitions, I see /dev/mmcblk0, presumably the eMMC. There's also /dev/mmcblk0boot0, /dev/mmcblk0boot1, and /dev/mmcblk0rpmb, which I presume are premade partitions on the eMMC. I've considered creating partition tables for these "devices," but I'm afraid this might create another problem. Then there's /dev/sdb, the external SD.

I've tried putting /boot onto either, and also trying efi (as well as the swap and / partitions). However, either the installation says GRUB2 couldn't be installed, or the entire installation will complete but the system will say there's no booting device when I turn it on. I've seen info that Linux might not like eMMC's that had Win8.1 by default, but I'm hoping there's a fix other than creating a LiveUSB, especially since the lack of a USB 3.0 port will make that quite slow as a primary OS.

Some material I've looked at has been over my head, so I apologize if the answer has been posted somewhere. Thanks for any help.

Edit: I'll include some more information. I've been trying to accomplish the installation from a LiveUSB made from Pendrive Linux's Universal USB Installer program. I've been creating the /, /boot, and swap partitions. The error I mentioned where grub fails to install occurs when I tried to create an efi partition.

8
  • 2
    First of all "/dev/mmcblk0boot0", "/dev/mmcblk0boot1", and "/dev/mmcblk0rpmb" should not be touched at all. If you aren't doing anything to it but it's the distro installer, then basically it has a bug. /dev/mmcblkN (/dev/mmcblkNpM) is simply like /dev/sdX (/dev/sdXY). grub-install in grub 2.02-beta2 can handle the mmcblk namings just fine. so either mint is using an even older release of grub2 (which is insane), or it's a bug of its installer again (well, or your pebkac).
    – Tom Yan
    Feb 13, 2016 at 20:32
  • FYI: git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/… the patch is pretty recent btw, so your first issue might be due to the fact that mint is with an old kernel
    – Tom Yan
    Feb 13, 2016 at 20:36
  • Would that create a problem in booting the OS? I thought the rpmb didn't have anything to do with boot configurations. I should mention that I've also tried a few flavors of Puppy, and none of those have worked either. Could I manually install grub outside of Mint's installer? And how would I do that.
    – Mike n Ike
    Feb 13, 2016 at 20:43
  • I don't think the issue will cause anything worse than error spamming in your kernel messages.
    – Tom Yan
    Feb 13, 2016 at 20:51
  • I'm honestly not concerned with that as I'm only trying to get a workable Linux installation for my friend who definitely won't be worrying about kernel messages. Perhaps I should also mention that in Mint's installer, I had marked /dev/mmcblk0 and /dev/sdb as the devices marked for bootloader installation, matching the device that I put the /boot or efi partition on.
    – Mike n Ike
    Feb 13, 2016 at 20:58

1 Answer 1

1

Thanks, Tom, for your help. I ended up solving this problem by using Unetbootin to make a LiveUSB with Mint 17.2 (instead of 17.3) and then installed it, and it went smoothly. You're probably right; there must be a bug in the 17.3 installer, or maybe in Pendrive Linux's program.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.