I was trying to make a backup onto a 8 TB Seagate SATA disk, so I placed the disk into a USB 3 adapter QP0020 by LogiLink and initialized the disk to be a GPT disk, using the whole capacity in one partition. I formatted the disk as NTFS. So far, everything was fine. I haven't started the backup process yet, since it was already late.

For whatever reason, I then placed the disk into a USB 3 adapter FD2002 by inateck and I expected to get a drive letter. However, no drive letter was assigned, so I looked up the Computer Management from control panel to see what it says. I was astonished to see that the disk was reported as "not initialized".

The screenshot shows the difference:

Screenshot of Computer Management

Now, I have an identical disk and I tried the same, but in the opposite order (inateck first, then LogiLink) and the result is the same (the disk can only be read with the original USB adapter).

Is this behavior expected and I can read the disk only in the correct USB adapter? What could be the reason and how to correct this problem? How to figure out which USB adapter behaves correctly and which one not?

Additional info

System: Windows 7 SP1 x64

Disk: Seagate 8 TB ST8000AS0002

USB 3 adapter 1: LogiLink QP0020

USB 3 adapter 2: inateck FD2002

Info from disk working in inateck adapter:

I:>fsutil fsinfo ntfsinfo i:
NTFS Volume Serial Number :       0xc050007050006f88
Version :                         3.1
Number Sectors :                  0x00000003a37d1fff
Total Clusters :                  0x00000000746fa3ff
Free Clusters  :                  0x00000000746e64e4
Total Reserved :                  0x0000000000002780
Bytes Per Sector  :               512
Bytes Per Physical Sector :       4096
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 1024
Clusters Per FileRecord Segment : 0
Mft Valid Data Length :           0x0000000000040000
Mft Start Lcn  :                  0x00000000000c0000
Mft2 Start Lcn :                  0x0000000000000002
Mft Zone Start :                  0x00000000000c0040
Mft Zone End   :                  0x00000000000cc840
RM Identifier:        F81B5903-C5F1-11E5-BEA2-B8AEED78FC51

It is possible to initialize the disk after changing the adapter.

Info from disk working in LogiLink adapter:

J:\>fsutil fsinfo ntfsinfo j:
NTFS Volume Serial Number :       0xf81685e71685a76a
Version :                         3.1
Number Sectors :                  0x00000000746fa3ff
Total Clusters :                  0x00000000746fa3ff
Free Clusters  :                  0x00000000746e64a6
Total Reserved :                  0x0000000000000000
Bytes Per Sector  :               4096
Bytes Per Physical Sector :       <Not Supported>
Bytes Per Cluster :               4096
Bytes Per FileRecord Segment    : 4096
Clusters Per FileRecord Segment : 1
Mft Valid Data Length :           0x0000000000100000
Mft Start Lcn  :                  0x00000000000c0000
Mft2 Start Lcn :                  0x0000000000000002
Mft Zone Start :                  0x00000000000c0000
Mft Zone End   :                  0x00000000000cc820
RM Identifier:        92E5A9D7-D24C-11E5-AF57-005056C00008
  • What is the output of fsutil fsinfo sectorinfo i: when it's working? – Ben N Feb 13 '16 at 21:31
  • Apparently the inateck adapter failed to read the drive? Can you initialize the drive with it? – Tom Yan Feb 13 '16 at 21:45
  • Unless the LogiLink adapter does encryption automatically (not necessarily with a password), I don't see how this is expected. – Tom Yan Feb 13 '16 at 21:47
  • Unless I'm missing something, you didn't post the info when connected to either adapter. Please provide both. – Daniel B Feb 13 '16 at 21:49
  • @TomYan: I believe I could initialize the disk in the other adapter. I'm not sure I should try that right now, because the backup on one of the disks is in progress and I only have the other available. It might invalidate the information I posted for BenN – Thomas Weller Feb 13 '16 at 21:51

It appears that one enclosure (the LogiLink QP0020) is forwarding the ATA commands directly to the drive, and the drive is operating in 512e mode. That means that, even though the drive physically has Advanced Format 4KB sectors, the enclosure and your OS see ye olde 512-byte sectors and so the OS lays down the partition table appropriately for that style.

The other enclosure is causing the drive to appear to the OS as having 4KB sectors. (The drive translates physical 4KB sectors to 512-byte sectors to the enclosure, which translates those back into 4KB sectors for the OS!) Therefore, when Windows requests data (since lots of stuff is sector-addressed), it's not in the right place. This is a common problem with switching drives between enclosures that have different behavior with respect to Advanced Format. Further reading: Rod Smith's excellent answer and my history of sector addressing.

You're in a tough spot. You'll need to choose one enclosure (i.e. sector size) and stick with it, otherwise your data will appear to jump around.

  • Damn it :-) So after I create a backup and if the USB adapter breaks, I'll need to find a compatible one? May I have the same issue if I connect the drive to an internal SATA port? – Thomas Weller Feb 13 '16 at 22:10
  • @ThomasWeller That's correct. Normal SATA ports will almost certainly produce the same result as the first adapter. – Ben N Feb 13 '16 at 22:13
  • Try to initialize the drive with both adapter and after each initialization, connect it to a SATA port and see which initialization works properly with it. You should probably use the adapter for the disk that did the working initialization. – Tom Yan Feb 13 '16 at 22:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.