I recently purchased a 4k tv to use as a monitor.

I was easily able to get it to work at 30hz by using the windows screen resolution dialog.

However, it took me awhile to get it to work at 60hz - the trick was I had to use the NVIDIA Control Panel. This was on Windows 10.

When I did this, it also hid a drop down that allowed me to switch the color from between 4:4:4 and RGB. I am guessing that this is because my tv only supports 4:2:0 at 60hz.

Unfortunately, as soon as I switched to 60hz, I noticed a number of additional problems.

1) Certain windows would flicker (like they were being redrawn slowly), but others not all. For example, the task manger would flicker quite heavily. The NIVIDIA Control Panel flickered a little bit, and some other programs, like MS paint, did not flicker at all.

2) The text mouse cursor, the one that looks like an I beam, got clipped so only the top half was visible - it looked like a T shape. The standard white arrow looked fine - as did all of the resize/move cursors that I saw (although I will admit I probably didn't check every possible cursor that exists).

3.) The mouse cursor did not move smoothly - I was definitely getting 60hz refresh rate for some things. The tv said it was getting a 60hz signal, and I used the UFO Test on the Blur Busters website. The mouse, however still basically looked like it was moving at 30hz.
Link: http://www.testufo.com/#test=framerates

While I was messing with the windows graphical options, I noticed something very strange - if I ran the windows magnifier application, all of these problems disappeared, and everything was basically working fine. As soon as I closed it, all 3 of the above problems reappeared.
*Note that you don't actually have to DO anything with the magnifier other than have it open. I set the view to "full screen" and the zoom to 100% which does nothing at all - well, nothing except fix the aforementioned bugs.

I used NVIDIA Shadow Play to record this (although I haven't uploaded the video anywhere because even though its less than 20 seconds long its still quite huge since it's 4k, and I expect that it would get down sampled quite a bit regardless) Anyways, on the shadow play recording, it recorded exactly what I saw, with the exception of the T instead of I as a text cursor issue - it showed the correct I on the video.

Anyways, at this point I had become quite frustrated with Windows 10 in general (main motivation was that I couldn't get javascript to work, but that's neither here nor there), so I Downgraded back to windows 8.1 before my 30 days ran out.

On windows 8.1, things were actually a little better.

After fiddling a bit to get it running at 4k 60hz, it was working pretty good - the task manager no longer flickered, and the mouse pointer seemed to move smoothly at 60fps.

The only problem that remained was the I shaped mouse cursor, which didn't look like a T this time, it looked like it had been shrunk slightly horizontally with a really terrible algorithm - the vertical bar was gone so all that remained was the top and bottom of the I, which seemed a tiny bit skinnier than normal, and were a little discolored. (This made it really hard to see)

I also had a problem with the black border of the cursor disappearing when i RDP'd into a windows server 2012 server for work. The mouse was usable mostly, except that it would effectively disappear completely when against a white background. (I did what I needed to do for work and I am logged off now, and I didn't bother to test the magnifier fix for work. I will update when I do, but I kinda expect that it will fix it.)

I tried to remedy this by switching to different mouse cursors, and I may have gained a little insight into the problem - it seems that the mostly white cursors work fine (ex: the default arrow and move cursors) but the mostly black ones are distorted and miscolored. I switched to the black cursor theme and my normal mouse pointer ended up looking like the screenshot in the first post of this thread: https://forums.geforce.com/default/topic/780518/4k-60hz-weird-graphical-cursor-bug/ (If that link disappears - the cursor is squashed horizontally and discolored.)

Now, this is Windows 8.1, but I figured I would try the magnifier fix again. Indeed, it worked, and as long as I keep the application open.

Also, in the thread on the geforce forms, someone mentioned turning on pointer trails. That seems to fix my I cursor issue, but I despise cursor trails so I would rather just leave the magnifier open all the time.

42" Class 4K Ultra LED HDTV

Video Card: EVGA GeForce GTX 980 SC

Cable: HDMI High Speed

Does anyone run windows 8.1 or 10 at 4k 60hz and get the correct mouse cursors all the time? If so, what did you have to do to get it to work, or what hardware are you using?

4 Answers 4


Edited Post to add my resolution as of 10:30am PST Allen - oddly the Windows 10 Upgrade does not 'keep' your NVidia Experience or the latest Game Drivers. I noticed we're both running EVGA super clocked (sc)cards.

I figured it out when I tried to test the system in Fallout 4 at 4k. Repeated graphics-driver crashes and finally a win32kbase.sys error woke me up. Went to 'open' NVidia Experience and it wasn't even on the machine. Even though the NVidia Control Panel was - it had some generic driver. The newest drivers were there before the Upgrade to Win10 and I just assumed the upgrade would keep the drivers intact. It's doesn't.

So I downloaded and installed NVidia Experience, checked for updated drivers - then installed them, and I'm all good.

No flicker in any system windows - Fallout 4 in 4K awesome. Hope this is the same for you. Good luck.

Original Post: Wanted to add to Allen's question as I have the same issues on number 1 and 2 of his list.

  1. The EXACT same windows flicker the exact same way. NVidia Control not as much as the Task Manager (heavy flicker)

  2. Mouse curser for TEXT looks like a T as the bottom of the cursor is missing.

Same as Allen I upgraded to Windows 10 last night. However my setup is different so maybe that will help.

I'm running two(2) EVGA SC GTX Titan X NVidia cards in SLI to a Sony XBR 43X830c UHDTV. The system is running well at 3840 X 2160 at 60Hz.

I'm using an HDMI high speed Monster cable at 27Gbps transfer.

It really flickers badly in EVGA OC Scanner X Benchmark application.

But doesn't flicker at ALL in Edge (Internet Explorer) The Desktop itself is perfect.

Dropdown menus flicker badly.

Hope this helps, and thanks to anyone for ideas. Slade

  • I had a similar but different experience. When I upgrade from Windows 8.1 to 10, geforce experience was still installed and appeared to be working. It also said that my drivers were up to date (but I don't know if this was actually true). However, after downgrading to 8.1 and reading you reading your post, I checked again, and this time GeForce experience was not working (despite the fact that it worked before I upgraded to 10, and it worked in 10). I uninstalled everything from NVIDIA using the add/remove programs menu. Then I reinstalled GeForce experience, updated all drivers, and it works!
    – Allen
    Feb 14, 2016 at 21:28
  • ...the reason that I say that "I don't know if [GeForce experience's claim that my drivers were up to date] was actually true", is because I seem to remember the version number being 344.XX or ssomething like that when I checked in windows 10 using GeForce experience... Now it's saying 361.75.
    – Allen
    Feb 14, 2016 at 21:34

I managed to solve my issue.

I lowered my resolution down to 1080p, and completely removed all NVIDIA drivers from the system (this required several restarts).

I was unable to uninstall GeForce experience, but I did go to the NVIDIA site and installed the latest version.

I then used GeForce experience to reinstall all of the drivers. I chose custom install, instead of automatic, and told it to remove any old settings as well, just to be safe.

This resolved my cursor issue in Windows 8.1

The lesson here is GeForce experience may not work right after an OS upgrade, and if you are having issues, it would be good to reinstall everything even if GeForce Experience claims to be up to date.


I have a Geforce GTX 1070 on Windows 10 and was running Nvidia's Geforce drivers version 378.78. Everything was fine and the picture looked great until Windows 10 auto-updated my Nvidia driver and I ended up with the exact same issues described in the original post.

Geforce Experience was still installed and it offered to install the latest Nvidia driver at the time (388.33) but it had the same problem. I uninstalled 388.33, cleaned up the leftovers with Display Driver Uninstaller (DDU) and reinstalled 378.78. The issues were gone so some driver version between those two releases introduced the issue. I then let Experience upgrade to the latest driver at the time I write this (388.43) skipping the Windows Update version but again the issues reappeared.

My Solution

Googling found this page and several workarounds but this YouTube video by Daddy James Films had the solution that worked for me: Go into your TV's picture settings and turn on HDMI UHD Color (as Samsung calls it). It somehow optimizes the picture quality for HDMI UHD connections. It may also be called HDMI Ultra HD Deep Color or HDMI 2.0 UHD True Color (as seen in the video).

After turning this on, my video card reacted by dropping to 1080p but it let me go back to 4k at 60hz. Yay! No more flickering!


This is an NVidia driver issue clean reinstall driver and reboot

  • Welcome to Super User. Do you have a source link or any other information you can add to corroborate this assertion? Nov 3, 2017 at 2:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .