1

I have a new in box Lenovo h30-05 PC that I planned on installing FreePBX distro on. I have had success with the exact same model a few weeks ago, but I am now ready to throw this current machine out of the window!

Let me begin:

I have disabled secure boot, enabled CMS, stated to boot legacy only, and changed the boot order to make the hard drive last. I have tried booting from 2 bootable CDs (Windows 7 and FreePBX Distro) which definitely work on other machines and also a USB FreePBX Distro which worked on a different computer just fine. Anytime I let it boot or if I manually select the device to boot, the screen goes back, the system powers off and on, and I am back at the Lenovo splash screen. It basically boot loops over and over to no avail.

I have defaulted the bios settings and changed them about 20 times now with the same results. I have also taken the CMOS battery out for 15 minutes, cleared the CMOS via the jumper, and I am still getting the same results.

Can someone possibly tell me what may be happening and why I cant boot any legacy device? It has Windows 10 preloaded on it but since Ive changed all of the above, it will no longer boot even when re enabling secure boot.

Thanks to any and all suggestions/solutions!

0

Try disconnecting the hard drive physically. Sometimes even if it's set as "last" in the boot order, the BIOS tries to "help" by booting it as non-UEFI and then failing and rebooting, as you are experiencing.

If that was the problem, you should at the very least now get an error message, if not a successful legacy boot.

Edited with additional troubleshooting from comments:

  • Is the CD drive's SATA controller set to IDE mode (not ASPI)?
  • Is the motherboard flashed to the latest firmware?
| improve this answer | |
  • Just attempted that after reading your post. I removed that SATA cable from the hard drive and the issue still happens. I tried booting from the DVD and USB drive. – Bifur Feb 14 '16 at 21:51
  • Is the CD drive's SATA controller set to IDE mode (not ASPI)? – Mekki MacAulay Feb 14 '16 at 21:53
  • Also, have you tried flashing the latest BIOS firmware? support.lenovo.com/ca/en/products/desktops-and-all-in-ones/… - Win10 may have done something stupid to an older BIOS. – Mekki MacAulay Feb 14 '16 at 21:55
  • Well, since Windows 10 will no longer boot since changing a lot of the settings, I will make a USB Windows 10 installer and try updating the bios. It will also be an indicator if the system will boot UEFI media correctly. – Bifur Feb 14 '16 at 22:03
  • Good call. Let us know how it goes. – Mekki MacAulay Feb 14 '16 at 22:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.