0

I use Bootcamp for Windows and rEFInd boot loader for Ubuntu 14.04. It used to work fine. Macbook Pro late 2014, came with Yosemite, upgraded to El Capitan.

I was booted into Ubuntu and out of the room. When I came back the screen looked strange, black & smeary, I think my cats walked on the keyboard. Also the fan is racing, but the computer isn't hot.

I rebooted. I had trouble starting Ubuntu, I booted the Mac Recovery Disk, which went straight to Internet Recovery - because the recovery partition is still Yosemite. I made a bootable USB with El Capitan. It doesn't have the Apple Hardware Test tools, and when it starts it says the battery isn't detected, but the battery is working. However, when I connect the charger, the lights don't go on.

Then I was able to boot Ubuntu from rEFInd for a couple of days, but for the past two days I am unable to boot anything except OSX & the recovery drives (one internal, Yosemite, and the USB with El Capitan).

I tried to boot a live USB Boot Repair disk, but it doesn't boot. I can't start Windows either. I can't start any OS except OSX.

I reinstalled rEFInd v 0.10.2. I used the install script in the El Capitan recovery boot because SIP was turned on. I also disabled crsutil in the terminal there.

When I try to boot Ubuntu in recovery mode it hangs at "Loading initial ramdisk" - I added nomodeset to the commands and searched a lot for a solution before posting here. I'm pretty sure that is also why the Boot Repair disk doesn't boot.

I ran a scan with Avast Antivirus.

In the El Capitan boot I tired to restore a previous Time Machine image, but it didn't find any, but I should have a couple since installing El Capitan. I have to restore from that boot because my Recovery HD partition is still Yosemite which came installed.

Another weird symptom is sometimes when I boot OSX wifi is off and I can't turn it on. Then I reboot and it's turned on.

I'm starting to think there is a hardware fault - is there something I am missing? Should I try rolling back to Yosemite? The triple boot was working fine after installing El Capitan, until last week when my cats borked it.

  • The cat ate my homework.... – Moab Feb 15 '16 at 22:50
0

It turned out I had to reset the System Management Controller (SMC) - which makes sense, it was clearly a bios like problem.

To reset the SMC: Shut down the computer. Plug in the MagSafe or USB-C power adapter to a power source and to your computer. On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time. Release all the keys and the power button at the same time.

The first tech at Apple support listened to me explain the problem, and said, "so you can't boot the computer at all" - I said, "No, you're not listening to me" and he hung up. I had to create a new support case and when I talked to another tech, he mentioned SMC then he escalated it - the first thing I asked the 3rd guy was "how do I reset SMC?"

and it fixed everything

  • nothing visible happens when you reset it, hold down the keys and release them – decibel.places Feb 16 '16 at 1:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.