2

I've got a brand new HP Probook 430. Debian 8.3 stable was not able to meet requirements of new hardware. So I've upgraded to Debian testing (Stretch) and put a new kernel as well - 4.3. https://wiki.debian.org/DebianTesting + https://scottlinux.com/2013/11/23/how-to-install-newer-kernel-from-debian-wheezy-backports/

I've installed a proper driver for wifi - iwlwifi. I've a connection with a cable as well. Both cases - 50 Mbps nice Internet.

I've downloaded and installed successfully Viber 64 bit. I can start it and type my mobile number. At the next screen I've a notice: "An Internet connection is required to activate your Viber account. Check your connection and try again".

I've a PC with Debian 8.3 running Viber successfully. Both computers are connected to my router. PC - with a cable, laptop - with wifi n.

I've same Viber problem when I connect my laptop with a cable.

Any suggestions?

Best, Simeon

7
  • It is very difficult to diagnose a problem with so few info. You should use tcpdump on your eth0 connection, and see whether any packet at all leaves your pc, when you try to connect to Viber. Then show the output. It is very surprising that Viber can work on wifi but not on ethernet. Feb 15, 2016 at 11:47
  • To be clear - no Viber connection with both cable and wifi on laptop. PC is another computer, connected to same router with cable and running Viber successfully. So router should not be a problem. I'll paste my console log from tcpdump in a few hours, when having access to the laptop.
    – user559322
    Feb 15, 2016 at 12:08
  • root@debian:/home/omi# tcpdump tcpdump: verbose output suppressed, use -v or -vv for full protocol decode listening on wlp2s0, link-type EN10MB (Ethernet), capture size 262144 bytes 16:46:19.440636 IP debian.49505 > 89.190.192.247.domain: 21472+ A? secure.viber.com. (34) 16:46:19.440681 IP debian.49505 > 89.190.192.247.domain: 20323+ AAAA? secure.viber.com. (34) 16:46:19.441578 IP debian.38986 > 89.190.192.247.domain: 5671+ PTR? 247.192.190.89.in-addr.arpa. (45) 16:46:19.446013 IP 89.190.192.247.domain > debian.38986: 5671 NXDomain 0/1/0 (126)
    – user559322
    Feb 15, 2016 at 14:49
  • 16:46:19.490733 IP 89.190.192.247.domain > debian.49505: 21472 3/4/4 CNAME secure-wa-elb-42596758.us-east-1.elb.amazonaws.com., A 107.21.15.156, A 52.20.223.63 (328) 16:46:19.490771 IP 89.190.192.247.domain > debian.49505: 20323 1/1/0 CNAME secure-wa-elb-42596758.us-east-1.elb.amazonaws.com. (177) 16:46:19.491454 IP debian.50790 > ec2-107-21-15-156.compute-1.amazonaws.com.https: Flags [S], seq 2129437091, win 29200, options [mss 1460,sackOK,TS val 471405 ecr 0,nop,wscale 7], length 0
    – user559322
    Feb 15, 2016 at 14:49
  • 1
    @SimeonStavrev Please edit the question to include the console logs. They are unreadable when added as comments.
    – DavidPostill
    Feb 15, 2016 at 23:35

6 Answers 6

2

Found a solution:

Download the following certificates

Place them in /usr/local/share/ca-certificates

run sudo update-ca-certificates

1
  • Worked for me, and I did need the crt from GitHub (unlike hrv below).
    – Shane
    May 19, 2016 at 20:56
2

Placing certs in /usr/local/share/ca-certificates and running the script didn't work for me on Debian testing x64...

I only needed https://www.thawte.com/roots/thawte_Premium_Server_CA.pem

Downloaded it and copied/renamed as /usr/share/ca-certificates/mozilla/thawte_Premium_Server_CA.crt (needs to be .crt to be recognised). After that I did "sudo dpkg-reconfigure ca-certificates" when asked if I trust new certs I said yes, and then explicitly enabled thawte-Premium_Server_CA which resulted in:

    root@hvulin:/etc# dpkg-reconfigure ca-certificates
Processing triggers for ca-certificates (20160104) ...
Updating certificates in /etc/ssl/certs...
WARNING: Skipping duplicate certificate thawte_Primary_Root_CA.pem
WARNING: Skipping duplicate certificate thawte_Primary_Root_CA.pem
1 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d...

Adding debian:thawte_Premium_Server_CA.pem
done.
Updating Mono key store
Linux Cert Store Sync - version 4.2.1.0
Synchronize local certs with certs from local Linux trust store.
Copyright 2002, 2003 Motus Technologies. Copyright 2004-2008 Novell. BSD licensed.

I already trust 175, your new list has 178
Certificate added: C=IL, O=StartCom Ltd., OU=Secure Digital Certificate Signing, CN=StartCom Certification Authority
Certificate added: C=ZA, S=Western Cape, L=Cape Town, O=Thawte Consulting cc, OU=Certification Services Division, CN=Thawte Premium Server CA, E=premium-server@thawte.com
Certificate added: O=CAcert Inc., OU=http://www.CAcert.org, CN=CAcert Class 3 Root
Certificate added: O=Root CA, OU=http://www.cacert.org, CN=CA Cert Signing Authority, E=support@cacert.org
Certificate added: C=ZA, S=Western Cape, L=Cape Town, O=Thawte Consulting cc, OU=Certification Services Division, CN=Thawte Premium Server CA, E=premium-server@thawte.com
Certificate added: C=US, O="thawte, Inc.", OU=Certification Services Division, OU="(c) 2006 thawte, Inc. - For authorized use only", CN=thawte Primary Root CA
6 new root certificates were added to your trust store.
Import process completed.
Done
done.
1
  • This solution works for me. However, when reconfiguring ca-certificates, I decided to select "ask" when asked if it should trust and install new CA certificates. This opened another window, where I ticked the new Thawte certificate. May 16, 2016 at 10:25
1

For me the solution was to install libssl1.0-dev. I did sudo apt-get install openssl libssl-dev but this didn't help me.

Installing libssl1.0-dev did the trick.

1
  • This is the correct solution for me - Kali Linux on Debian 9
    – Pekov
    Dec 13, 2018 at 21:18
1

for fedora:

sudo dnf install openssl openssl-devel
sudo ln -s /usr/lib64/libssl.so.10 /opt/viber/lib/libssl.so

see: https://bytefreaks.net/applications/viber-desktop-on-fedora-27-64bit-viber-cannot-connect-to-the-internet-openssl-error for an explanation

1
  • 1
    That's all what was needed on FC30
    – yǝsʞǝla
    Jul 8, 2019 at 7:10
0

Maybe this help to you: sudo apt-get install openssl libssl-dev

1
  • More detail would help
    – Dave M
    Oct 29, 2017 at 19:52
-1

btw i had this problem and i downloaded ibssl1.0.0_1.0.1t-1+deb8u7_amd64.deb from link: https://packages.debian.org/jessie/libssl1.0.0 and installed and then again installed viber

after downloading ibssl1.0.0_1.0.1t-1+deb8u7_amd64.deb

and get into the file directory you put the downloaded file and type ls then type dpkg -i like this

dpkg -i libssl1.0.0_1.0.1t-1+deb8u7_amd64.deb then go back to the file directory where the viber.deb file is then type ls then type dpkg -i like this dpkg -i viber.deb

then good to go hope you got your error fixed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy