4

This problem is quite confusing. I have one desktop computer and one laptop. Both are running the same Windows version and build.

On my laptop, when I click on the start menu and start typing, relevant searches will appear instantly (without having to click on the "Search my stuff" button). This is how I want it to work.

Screenshot from the laptop:

enter image description here

On my desktop computer however, if I start typing I will have to click on the "search my stuff button" to get relevant results.

Screenshot from the desktop: enter image description here

Why is the search function acting differently on these two computers? Is there an option I have missed?

I have already made sure that the indexing is the same and that all the folders I want to search are included. I have also tried to rebuild the index.

Edit: Both computers have been on for hours and they both confirm that the Indexing is complete. However it seems that the laptop will only return search results instantly if the files are stored on the C drive. This does not make any sense since the indexing service is supposed to index files no matter which drive the files are stored on. Indexing should be instant, it is not a real-time full scan search.

  • Assuming you have the same files on both devices, this might be an indexing service problem. Did Windows on both devices had enough idle time to run indexing service? – Sanny Feb 15 '16 at 16:08
  • Both have had enough time (days and weeks) to index the folders, yes. – Arete Aug 10 '16 at 22:50
  • Might not be relevant, but does your laptop have an SSD? That certainly reduces the time Windows has to spend searching (indexed or not). – Dog Lover Nov 21 '16 at 21:43
  • Yes, my laptop has an SSD drive. – Arete Nov 21 '16 at 21:44
  • @Arete I had a thought - is your laptop set to the same display language as your desktop? Annoyingly, I had to set English (US) as my display language on one of my laptops as it would not search for settings when set to English (Australia). – Dog Lover Mar 26 '17 at 21:54
-1

This could be the result of disabling Windows Search in Windows Service.

Let try to enable it again by pressing Windows + R, type: services.msc to open Windows Service.

In there, search for Windows Search, double-click on it to open Properties.

In the Startup type, choose Automatic from the list.

Then reboot your Windows PC and wait for a few hours to all files get indexed. After that, you may be able to search for files instantly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.