73

I have a problem with a website that has an SSL certificate which doesn't correspond to the website domain. Chrome gives me a warning for this website (and rightly so), which I have to ignore manually. Every time I restart Chrome, I need to ignore the certificate issue again.

I've tried adding the certificate as a trusted one with certutil, using C,, and P,, trustargs, but it doesn't work. I can't find a set of trustargs that will tell it to ignore which domain is using the certificate.

Is there a way to tell Chrome (or certutil) to trust this certificate whatever domain uses it?

5 Answers 5

63

This is a summary of the answers from the thread
Disable Google Chrome warning if security certificate is not trusted.

You can avoid the message for trusted sites by installing the certificate.
This can be done by clicking on the warning icon in the address bar, then click
Certificate Information -> Details Tab -> Export...
Save the certificate.

Use Chrome's Preferences -> Under The Hood -> Manage Certificates -> Import.
On the "Certificate Store" screen of the import, choose "Place all certificates in the following store" and browse for "Trusted Root Certification Authorities." Restart Chrome.

11
  • 10
    Thank you, but this only works on Windows. On Linux, Chrome uses the certutil command line tool to manage certificates, nothing else.
    – raphink
    Commented Feb 11, 2010 at 11:30
  • 1
    It seems I can't select your answer as the right one anymore because the bounty expired :'(
    – raphink
    Commented Feb 15, 2010 at 9:24
  • 3
    No, it doesn't work on Linux, and the bounty cannot be relaunched.
    – raphink
    Commented Feb 22, 2010 at 9:43
  • 1
    FYI, this (now?) does work on Chromium 18, Ubuntu 12.04 - same instructions found here: superuser.com/a/41937/55046 Commented Jan 15, 2013 at 5:08
  • 3
    2 quick things to add to this: 1. It seems to work best if you go to the "Authorities" tab in the certificate manager, before clicking "Import..." (thus adding you, or whoever signed the certificate, as a trusted signer-of-certificates) 2. I'm not sure if I needed to, but I checked all the checkboxes under "Edit trust settings". Commented Oct 10, 2014 at 17:30
16

Using Chrome Version 23.0.1271.97 on Linux:

  1. First click on the certificate warning and export the certificate to your file system. (Connection > Certificate Information > Details > Export)
  2. Then use certutil in order to add this saved certificate as a trusted peer:

    certutil -d sql:$HOME/.pki/nssdb -A -t P -n <certificate nickname> -i <certificate filename>
    
  3. Restart Chrome and you're done.

3
  • 2
    This worked for me, thanks! I had to run this first (opensuse linux): sudo zypper install mozilla-nss-tools Commented Sep 27, 2013 at 8:09
  • This is a great answer, if you want to understand better how it works, use certutil -H -A, and maybe read about trust flags in NSS Database: blogs.oracle.com/meena/entry/notes_about_trust_flags Commented Nov 25, 2015 at 8:24
  • to install certutil i used sudo apt-get install libnss3-tools
    – shatulsky
    Commented Jul 20, 2023 at 14:15
12

The only way I got it working in Chromium with Ubuntu Linux is using this certutil commandline:

certutil -d sql:$HOME/.pki/nssdb -A -t "CP,CP," -n CertNickName -i cert_file.crt
5
  • 2
    This worked for me using Arch too.
    – Tim
    Commented Jul 23, 2015 at 8:48
  • That worked for me on Centos 7 Commented Sep 26, 2016 at 13:26
  • 3
    Worked Debian 9 also (requires libnss3-tools package installed first). Commented Nov 2, 2017 at 13:47
  • Worked for me on Debian 11
    – David Alsh
    Commented Mar 10, 2023 at 2:11
  • Works in Ubuntu 22.04, Chrome 120...
    – Md. A. Apu
    Commented Jan 3 at 12:21
4

Please have a look at this thread:
Can't convince Chrome that my Tivo's self signed certificate is ok.

The article remarks that:

You need to specify the "C,," trust flags to work around the NSS bug.

If this thread does relate to your problem, it looks like this is a known bug in Chrome, where the "P,," trust flags is not working: libpkix ignores the P (trusted peer) trust flag

I hope this helps (I'm answering a bit blindly, since I'm not on Linux).

1
  • Thanks, it seems to be related to my problem, and hence a bug in Chrome. I'll consider your suggestion as an answer to my question, even though it doesn't really fix my problem :-)
    – raphink
    Commented Feb 15, 2010 at 9:23
0

Google Chrome in Linux doesn’t have a SSL certificate manager, it relies on the NSS Shared DB. In order to add SSL certificates to the database you will have to use the command line. I will explain how you can add the CAcert certificates and a very easy way to add self-signed certificates.

Please have a look at this thread: blog.avirtualhome.com/2010/02/02/adding-ssl-certificates-to-google-chrome-linux-ubuntu/

4

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .