0

When right clicking a file in Explorer in my Windows 10, the sub menu of the context menu entry Open with is empty. I only have the option Choose another app

When i click on the Home tab in explorer and I click on the open dropdown, I correctly get the list of associated applications for a file type.

So my question is: How can I fix the right click context menu to show the list of associated applications?

After some googling I already tried this registry file:

Windows Registry Editor Version 5.00 
[HKEY_CLASSES_ROOT\*\shellex\ContextMenuHandlers\Open With]
 @="{09799AFB-AD67-11d1-ABCD-00C04FC30936}"

But that didn't fix the problem and seems to be only to restore the Open with entry if it is completely missing.

Update: It seems the context menu only shows programs from my local hard drives, and does not list programs that are on a network share. So how do I get the applications from my network share listed. (I use a drive mapping for the network share)

  • Once you choose an application via Open with, it should get added to the open-with listing (or sub-menu).. as the OpenWithList or OpenWithProgId values are populated when you choose an application. The "Open with" option you see in the ribbon works differently. – w32sh Feb 21 '16 at 16:11
  • Interesting: When I choose open with from the context menu and I choose Notepad++, the application is added to the list. But when I used a MFC or command line program, it is not added to the list whilst the ribbon list gets the entry. – Gerd K Feb 22 '16 at 13:19
0

If by context menu you mean This Context Menu then you need to do a few simple things, as well as be an administrator. This worked for me but may not work for you, but I hope it does.

enter image description here

The first thing you want to do is head to NirSoft and download the ShellExView. After that you should run the program, and sort by Microsoft and Non-Microsoft. It should look like this.

enter image description here
(Click image to enlarge)

Then select the grey ones that you need, right-click and "Enable Selected Items".

  • Using ShellExView, I see 'Open With Context Menu Handler' as enabled. I also have the menu entry, but the list is empty. – Gerd K Feb 22 '16 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.