1

My CPU(FX9590) clock speed stays at 1.37 GHz all the time even while gaming, but my maximum frequency is able to reach 4.72 GHz at most.

I tried to change the clock speed through AI Suite II(I am using Asus Formula Z as my Mainboard) but it didn't help at all.

My energy scheme is on high performance and I never changed it, so it has nothing to do with this.

  • Just to make sure its not measurement error, can you confirm that your frequency is stuck in CPU-Z? cpuid.com/softwares/cpu-z.html – Frank Thomas Feb 16 '16 at 20:41
  • I didn't install CPU-Z, but I think the frequency is stucking. Because clearly I felt something is not right while I play games. The lag within low setting just could not happen with my hardwares. – McR3v3n5 Feb 21 '16 at 11:51
0

In order for the turbo to work, all settings in your BIOS have to be set to auto, and the turbo feature has to be enabled.

If you have that enabled but it still is not getting this speed, it is likely that your cooling is not optimal, and it clocks down due to prevent overheating.

  • I don't think it has anything to do with cooling. I am using water cooling system. a – McR3v3n5 Feb 19 '16 at 12:01
  • @McR3v3n5 I was just being thorough. – LPChip Feb 19 '16 at 22:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.