256

This should be pretty trivial, but I can't find a way to get it to work.

I want FFmpeg to take one JPEG image and an audio file as input and generate a video file of the same duration as the audio file (by stretching the still image for the whole duration).

I don't care very much about what video codec is used for output, but it is vital that I can use "copy" as the audio codec (i.e. copy the audio stream without transcoding it).

What is the right command line that would do that?

I tried:

ffmpeg -i image8.jpg -i sound11.amr -acodec copy test.avi

and tried a lot of combinations with and without -s 640x360, -loop_input, -shortest, -t xxx, -r 0.1 (artificially low frame rate in the hope that the video would be longer) and -f image2

Either I get errors or I get a video file of the duration of one frame.

I've googled around and found a dozen of proposed solutions (supposedly to this very same question) none of which works.

Can anybody suggest a working command and explain the rationale behind it?

9
  • I just tried your command line and it worked as expected. Your problem might lie with the sound format. Does transcoding the sound work? May 4 '11 at 17:49
  • By "as expected" do you mean the resulting video has the same duration as the audio input? Have you played it? Isn't it one-frame-long?
    – matteo
    May 4 '11 at 17:59
  • Sound format is not the problem, transcoding the sound works
    – matteo
    May 4 '11 at 17:59
  • 9
    this is better than chosen answer, i experimented and it's fast and file size is small..ffmpeg -y -i image.png -i audio.mp3 -c:a copy result.avi Jul 7 '14 at 6:05
  • 1
    @MuhammadUmer Youtube can't process video created this way.
    – user218867
    Feb 12 '20 at 22:04

13 Answers 13

213

The order of options in the command line matters. The following works for my case:

ffmpeg -loop 1 -y -i image8.jpg -i sound11.amr -shortest -acodec copy -vcodec mjpeg result.avi

In a more general case, where image.jpg and audio.wav are your input, you can use the following command, adapted from the FFmpeg wiki:

ffmpeg -loop 1 -i image.jpg -i audio.wav -c:v libx264 -tune stillimage -c:a aac -b:a 192k -pix_fmt yuv420p -shortest out.mp4

This would use the libx264 encoder and provide you with better compression than the MJPEG codec used above. The audio is AAC, with the built-in ffmpeg AAC encoder.

22
  • 14
    How come the files end up so much bigger than [size of image] + [size of audio file]? I would expect the video compression to go crazy with a constant frame? Apr 13 '12 at 7:01
  • 2
    It depends on the video codec you use. If you are copying the commands in my examples, I'm using mjpeg as the codec, which compresses each frame separately, so it takes no advantage of the fact that all frames are equal. Also, I think that even other codecs would recode the whole frame every once in a while, i.e. every N-th frame, so you would get a much smaller file but still much bigger than just the size of the image+sound. They do so because (a) otherwise the decoder would need to read the whole file from the beginning even if you just want to jump to the last frame, and
    – matteo
    Apr 13 '12 at 10:43
  • 2
    Option shortest (finish encoding within shortest input) cannot be applied to input file image.jpg -- you are trying to apply an input option to an output file or vice versa. Move this option before the file it belongs to.
    – wim
    Dec 16 '13 at 1:14
  • 7
    use ffmpeg -y -i image.png -i audio.mp3 -c:a copy result.avi this works better!!!?!??!?! Jul 7 '14 at 6:07
  • 2
    This answer is currently being discussed on meta.
    – DavidPostill
    Feb 14 '16 at 8:42
58

Even easier:

ffmpeg -i ep1.png -i ep1.wav ep1.flv

FFmpeg will try to pick the best codec automatically, depending on the extension of your output file.

Update: I noticed YouTube has difficulty processing the video (gets stuck at 95%) I think because there's only one frame. The solution I found to make YouTube happy: add more frames. Also, I added-acodec copy to preserve the audio quality. You need -shortest or it loops forever. (It stops at the end of the shortest stream, which is the audio, because the image loop is infinite.) The order of your options is very important for speed, as filters (and such) are processed in the order you specify. If you change the order of these parameters, the results are dramatically different.

ffmpeg -r 1 -loop 1 -i ep1.jpg -i ep1.wav -acodec copy -r 1 -shortest -vf scale=1280:720 ep1.flv

Also notice that I set the frame rate twice, that's not an accident--the first frame rate is for the input, second is for the output. If you do this correctly, there should only be one frame per second of video, which means it encodes relatively fast. Also I set the resolution to 720p here, which means you should get HD audio on YouTube :-)

10
  • Also it's possible your audio file won't be compatible with your .flv container. In that case, you should just try a different (output) container, like .webm, .avi or whatever format, till you find a container format that's compatible with your audio file.
    – PJ Brunet
    Sep 29 '15 at 2:50
  • 2
    Used this for a .JPG and .MP3 to make an MP4 - worked perfectly. The FLV I created from the JPG/MP3 didn't seem to work - which may be as per the previous comments warning.
    – pperrin
    Oct 29 '15 at 14:37
  • 3
    The updated version works, for Youtube. I thought it was stuck at 95% but finally it worked.
    – Basj
    Feb 28 '16 at 10:24
  • 6
    ffmpeg -r 1 -loop 1 -y -i 1.jpg -i 1.m4a -c:a copy -r 1 -vcodec libx264 -shortest 1.avi this should be the best answer, '__') only took 2 secs to encode, the other answers took more than 10 minutes and resulting in a very huge size
    – Kokizzu
    Nov 8 '19 at 5:00
  • 2
    Awesome! The second update worked for youtube
    – Paolo
    Oct 23 '20 at 8:22
46

You're making it way harder than it has to be. FFmpeg is a lot smarter than you give it credit for--it knows you want the video to be the same length as your audio track.

ffmpeg -i still.png -i narrate.wav -acodec libvo_aacenc -vcodec libx264 final.flv

pause

The only attributes you have to specify are the input filenames, the output codecs, and the output filename (which eo ipso includes the output container, ).

Of course, it makes sense to start with a still image that shares the same dimensions as your eventual video; if you are using a dedicated image editor instead of specifying output dimensions for FFmpeg to meet, you need to make sure your input dimensions are even numbers.

Output size is one of FFmpeg's most common hang-ups; some codecs are more restricted in output dimensions than others, but no output can have odd-number height- or width attributes.

The pause command at the end of the batch file keeps the CLI open--the best way to debug your command line is by reading the error messages it generates. They are extremely specific--and the best documentation FFmpeg has--but the developers' hard work is wasted if you allow the window to close before you can read them.

The command shell has a switch cmd /k that maintains an open window where you can run the same the same instructions from your batch script at the command prompt.

FFmpeg and avconv will both make you use -c:a for -acodec and -c:v for -vcodec eventually, but the old instructions work fine in the builds I use.

Nota Bene: Every commit has idiosyncracies. If your command line is failing for no apparent reason, it is often helpful to try another build--or follow the fork over to libav, where FFmpeg's most active developers have been for the last couple of years. Their transcoding tool has been renamed avconv but your batch files should work with either one.

7
  • I must be using a different version than youurs (if you have tried your command and it works as you describe), because, as I already mention in the question, I had already tried your exact same command and I get a video of the duration of 1 frame (a fraction of a second), NOT the duration of the audio file. I did expect it to be intelligent, but (in my version) it proved to be not.
    – matteo
    Dec 16 '12 at 19:59
  • 2
    Hey Matteo, yes, I did execute that code, and yes, it works as advertised. I'm sure there are plenty of halfwits that would be so careless as to make such claims without testing them, so I'll try not to be offended :) In a full post below I will supply Pastebin links to FFmpeg console output and MediaInfo data on input files and final output file. My input files, my batch file, my output file are on a GoogleDrive where they are freely downloadable, if you would like to test them against your FFmpeg build.
    – patronanejo
    Jan 5 '13 at 12:59
  • @ShinMuraoka Mine is a win-64 ffmpeg build compiled on: Jan 6 2013, at: 16:16:53 Neither your solution nor @matteo solution worked for me. Also, I downloaded your files from Google Drive, but it didn't gave the expected output (the output file was black contained only audio). Please help me in figuring out the right command to be used. Jan 8 '13 at 17:47
  • 2
    "no output can have odd-number height- or width attributes" Not true. Set pix_fmt to something that doesn't have chroma subsampling, like rgb24 or yuv444p, then make sure the codec and container support it and have no further restrictions. With regards to pix_fmt, FFmpeg is less than intelligent; it assumes yuv420p (which has chroma subsampling) unless you tell it otherwise. May 29 '13 at 2:49
  • what about multiple images? I need the image to change at some specific time to another image. I'd like to be able to specify them on the command line with a time parameter for each one.
    – user153343
    Jun 8 '17 at 13:23
21

The version that worked for me:

 ffmpeg -loop 1 -y -i pic.jpg -i sound.amr -shortest video.mp4

Checkout the the option -shortest must to be in front of the output file if not I get the below error:

Option shortest (finish encoding within shortest input) cannot be applied to input file pic.jpg -- you are trying to apply an input option to an output file or vice versa. Move this option before the file it belongs to. Error parsing options for input file pic.jpg.

2
  • 2
    Thanks for this. Most of the other answers didnt work for me (using ffmpeg on Alpine linux). This answer has the shortest command that worked flawlessly for me.
    – DannyB
    Jul 6 '17 at 13:38
  • ffmpeg -loop 1 -y -i slide02.jpg -i slide02.aac -shortest slide02.mp4 # thanks just what I needed
    – zzapper
    Jun 16 '20 at 18:32
8

From the ffmpeg manpage:

ffmpeg [[infile options][-i infile]]... {[outfile options] outfile}...

As you discovered, the infile options must come before the infile to which they apply.

This is not a bug, however, just a mechanism by which you can specify which infile arguments apply to.

1
  • what about multiple images? I need the image to change at some specific time to another image. I'd like to be able to specify them on the command line with a time parameter for each one.
    – user153343
    Jun 8 '17 at 13:23
6

Here is a full explanation:

ffmpeg -i image.jpg -i audio.mp3 -c:v libx264 -tune stillimage -c:a copy out.mp4
  • -i image.jpg -i audio.mp3: Image and audio inputs

  • -c:v libx264: use x264 to encode video.

  • -tune stillimage: x264 setting to optimize video for still image encoding

  • -c:a copy: copies the codec used for the input audio. You may change this if you want a different audio codec.

I did not use -loop 1 or -shortest. -loop 1 drastically slows down the encoding and creates a larger file. -shortest should not be used without -loop 1 since then the video will be one frame long. However YouTube does not like videos with one frame (see PJ Brunet's answer) so then both options should be used.

1
  • When I tried creating a video using this method, my version of Movist (a macOS video player) only played the video for a split second, and my version of VLC displayed a black background instead of the background image. A video created using PJ Brunet's method played correctly in VLC, but there was no audio in Movist. I didn't really even need a background image, so I ended up using a low-resolution black background to reduce file size and encoding time: convert -size 256x144 xc:black /tmp/a.png;ffmpeg -loop 1 -i /tmp/a.png -i input.m4a -c:v libx264 -crf 51 -c:a copy -shortest output.mp4.
    – nisetama
    Apr 13 '20 at 17:01
5

This worked for me:

ffmpeg -loop 1 -shortest -y -i image.jpg -i audio.mp3 -acodec copy -vcodec libx264 video.avi

I found vcodec libx264 created much smaller files than mpjeg (10 MB rather than 100 MB).

1
  • 2
    -shortest is an output option and may be ignored as an input option as you are using it.
    – llogan
    Feb 15 '16 at 21:55
3

Cloned from PJ Brunet's answer:

ffmpeg -r 1 -loop 1 -y -i 1.jpg -i 1.m4a -c:a copy -r 1 -vcodec libx264 -shortest 1.avi

This resulting the smallest size (18MB) and fastest encoding time (only took 2 secs for 17MB m4a file)

2

I was trying to do as @matteo, but without the audio, and @Colonel Panic's solution worked best :

ffmpeg -loop 1 -shortest -y -i still.png -vcodec libx264 -t 10 video.avi

I only had to add a duration argument in seconds (-t 10).

1
  • -shortest is an output option, but you're using it as an input option. Move it before the output file and you can eliminate the -t 10, but then your answer will be pretty much the same as the others.
    – llogan
    Feb 15 '16 at 21:51
1

In case someone wants to batch convert them, try this.

You can set the input and output Folder, and also the format in which you want the video to be in. In this case I set it to AVI.

This answer Combine one image + one audio file to make one video using FFmpeg helped me a lot.

 @echo off
 set "sourcedir=C:\Users\CodeHard\Desktop\BOX\Newfolder"  
 set "outputdir=C:\Users\CodeHard\Desktop\BOX\Converted" 

 PUSHD "%sourcedir%"

 for %%F in (*.mp3) DO ffmpeg -r 1 -loop 1 -i abc.jpeg -i "%%F" -acodec copy -r 1 -shortest -vf scale=1280:720 "%outputdir%\%%F.avi"  

 POPD
1

I used a combination of a couple of the commands mentioned in this post, including -pix_fmt yuv420p to make sure it works on Quicktime (Mac).

ffmpeg -loop 1 -y -i image.jpg -i music.mp3 -shortest -pix_fmt yuv420p output.mp4

For me, this worked perfectly on macOS.

1
  • I too am on MacOS and my sound file is also MP3, but your command took longer and generated a larger MP4 then just letting ffmpeg figure it out as @PJ Brunet suggests: ffmpeg -i image.jpeg -i audio.mp3 result.mp4 ffmpeg version N-98301-gce297b44d3-tessus
    – Chris Wolf
    Sep 13 at 17:01
0

ffmpeg -loop 1 -i img.jpg -i audio.wav -c:v libx264 -c:a aac -strict experimental -b:a 192k -shortest out.mp4

2
  • 5
    Can you explain how the command you added works?
    – neelsg
    Jul 22 '14 at 12:20
  • 1
    This answer is not much different than the other simple "comment-answers" here.
    – llogan
    Feb 15 '16 at 21:52
-1

Try this command. It is worked for me.

-y -i /storage/emulated/0/images.jpg -i /storage/emulated/0/audio.wav -acodec aac -vcodec mpeg4 -s 480*320 -f mp4 -r 2 /storage/emulated/0/output.mp4"
1
  • 2
    This is an incomplete command that couldn't possibly work. Although I can fix and debug your command, I won't do your work for you, so please edit your answer and fix it yourself. I also noticed that your video size is not what matteo wanted.
    – karel
    May 24 '16 at 8:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.