When I attempt to boot the newly built computer from a USB in order to install windows 10, I get the error "Reboot and select proper boot device." I think that somehow my settings in the UEFI are not correct so that it is not attempting to boot from the USB as I'd like.

Some details:

  • Are you sure your USB is bootable? Have you entered the settings in UEFI to look at the boot order?
    – root
    Feb 17 '16 at 21:16
  • I have been trying to find the boot settings in the UEFI, but am not finding the boot order. Do you know where it might be?
    – naomisl
    Feb 17 '16 at 21:43
  • Once I do find the right place in the UEFI-- Is the idea that if the USB isn't bootable, I won't see it in the list for the boot order?
    – naomisl
    Feb 17 '16 at 21:44
  • it varies, but it's usually pretty obviously labeled "boot order". there should only be so many tabs to check
    – root
    Feb 19 '16 at 13:09

It doesn't make sense to dd a Windows ISO to a USB drive. It's simply not supposed to be bootable this way. For the PC to boot a USB drive, the drive needs to have either a MBR with proper boot code for hard disks, but not ISO9660/UDF, for BIOS/CSM, or a proper FAT-formatted ESP for UEFI.

The simplest way to make a bootable Windows installation USB for UEFI, is to format the drive with FAT32, and then mount the ISO and copy the content to it. UEFI simply looks for EFI binaries on proper location.

  • Thank you, this sounds promising! Can you walk me through it in a bit more detail? I wipe the usb, and then, how would you suggest I format it to FAT32 & mount the ISO to it?
    – naomisl
    Feb 17 '16 at 22:33
  • Use any tool you like to put FAT32 on it. You don't mount the .iso file to the disk; you mount the .iso file and then copy the files from within the .iso file to the USB drive. A tool like Rufus can help automate the process -- although I've never used Rufus to make a bootable USB from a Windows installation disc, so it might not be the right tool.
    – Rod Smith
    Feb 18 '16 at 0:17
  • Rufus worked for my BIOS system
    – Suici Doga
    Feb 18 '16 at 4:17
  • I ended up finding a windows machine and learning that my ISO file was corrupted, but this is the advice that would have worked if it wasn't corrupted so I'm marking it accepted. Thanks for your help!
    – naomisl
    Feb 19 '16 at 17:50
  • Just a heads-up, it looks like NTFS might be required for recent builds. FAT will boot, but eventually there's an error. Jul 20 '16 at 6:39

Annoyingly some USB drives aren't boot compatible with some computers and the only way to find out is try several USB drives, do you have any others to try, Sandisk seems to to good here?

  • Did you mean to put this as a comment instead of an answer?
    – Eric F
    Feb 17 '16 at 21:37
  • interesting...I could try that.
    – naomisl
    Feb 17 '16 at 21:43
  • 1
    I've found this to be true for BIOS-mode boots. I have yet to encounter a USB drive that's not bootable in EFI mode, assuming it's got the right files. Since the OP hasn't clearly specified BIOS- or EFI-mode booting, this might or might not be an issue, but it's certainly worth mentioning.
    – Rod Smith
    Feb 18 '16 at 0:15
  • 2
    @EricF This is an answer, not a comment. It benefits the site and future users to have alternate answers, even if they're not "the" answer for the original OP.
    – Bob
    Feb 18 '16 at 0:36
  • @RodSmith sir you just saved my life... Had the aforementioned problem, changed the setting which forced BIOS mode, now it's apparently working!
    – Selrond
    Apr 4 '17 at 15:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.