0

I installed Arch Linux with Secure Boot enabled using PreLoader. I enrolled the hash for loader.efi, containing rEFInd, and vmlinuz-linux using HashTools. The problem is that I get a message saying:

The system found unauthorized changes on the firmware, operating system or UEFI drivers. Press [N] to run the next boot device, or enter directly to BIOS Setup if there are no other boot devices installed. Go to BIOS Setup > Advanced >Boot and change the current boot device into other secured boot devices.

I always get this message twice. When I press N after the first message shows up, the rEFInd menu shows up. After I select Arch Linux and hit enter, the message shows up for the second time and I have to press N again to boot into Arch. It seems to me that the hashes are correctly enrolled, since both rEFInd and Arch is booting. I also checked the EFI boot entry, and it only contained the entries for rEFInd and Windows, so it can't be another unsigned boot loader getting in the way. Is there any way I can get rid of this message besides disabling Secure Boot? BTW, I'm using an ASUS motherboard with the latest firmware.

EDIT: I have the following files under /boot:

  • initramfs-linux.img
  • initramfs-linux-fallback.img
  • intel-ucode.img
  • refind_linux.conf
  • vmlinuz-linux
  • EFI/refind/HashTool.efi
  • EFI/refind/loader.efi
  • EFI/refind/PreLoader.efi
  • EFI/refind/refind.conf
  • EFI/refind/icons/*.png
  • EFI/refind/keys/*.cer

EDIT: output of efibootmgr -v:

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,0004
Boot0000* rEFInd Boot Manager   HD(1,GPT,276084db-5749-4226-8cd8-7e7d9e065af6,0x800,0x17a000)/File(\EFI\refind\PreLoader.efi)
Boot0001* Windows Boot Manager  HD(1,GPT,25a79d18-794f-4b9a-851b-cc4a02315628,0x800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0004  Hard Drive    BBS(HD,,0x0)AMGOAMNO........o.I.N.T.E.L. .S.S.D.S.C.2.C.T.2.4.0.A.4....................A...........................>..Gd-.;.A..MQ..L.V.C.I.K.4.2.4.8.1.0.C.A.4.2.D.0.N.G. . ......AMBOAMNO........o.P.L.E.X.T.O.R. .P.X.-.2.5.6.M.5.S....................A...........................>..Gd-.;.A..MQ..L.0.P.2.2.5.2.0.1.5.3.6.3. . . . . . . . ......AMBOAMNO........u.H.i.t.a.c.h.i. .H.D.P.7.2.5.0.5.0.G.L.A.3.6.0....................A.................................>..Gd-.;.A..MQ..L. . . . . . .E.G.5.A.1.3.E.R.G.0.9.S.A.Z......AMBOAMNO........u.I.N.T.E.L. .S.S.D.S.A.2.M.1.6.0.G.2.G.C....................A.................................>..Gd-.;.A..MQ..L.V.C.O.P.3.9.2.9.0.0.V.U.6.1.A.0.N.G. . ......AMBO
5
  • Do you have any EFI filesystem drivers installed in rEFInd's drivers or drivers_x64 subdirectory? If so, you must enroll their hashes, too. Also, look for stray binaries in the rEFInd directory -- it could be that PreLoader is trying to launch Binary X, failing because its hash is not enrolled, and falling back on Binary Y. – Rod Smith Feb 18 '16 at 14:26
  • Thanks for your reply I checked /boot, and I couldn't find any drivers or binaries other than vmlinuz-linux, initramfs-linux, intel-ucode.img, loader.efi, HashTool.efi, and PreLoader.efi. – Sora Minazuki Feb 18 '16 at 14:46
  • Please edit your question to show the output of efibootmgr -v. (Add four characters to the start of each line to preserve the formatting.) – Rod Smith Feb 18 '16 at 19:36
  • I updated my post. Maybe I should delete the third entry? – Sora Minazuki Feb 19 '16 at 9:46
  • 1
    It looks correct to me. I have two thoughts. One is that you might not be running from the Boot0000 entry, but from the Boot0001 entry, if PreLoader were installed in place of EFI\Microsoft\Boot\bootmgfw.efi. You can check for a loader.efi file there, or try launching it directly from the firmware's boot manager, to test this hypothesis. My other thought is that PreLoader might just not be working well with your firmware. In this case, switching to Shim makes sense. Shim now works with hashes as well as signed binaries, although my testing of it this way is limited. – Rod Smith Feb 19 '16 at 21:44
1

Switching to Shim did the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.