5

If I start a file download before starting the video upload then the download will continue at full speed while the video uploads, but if I try to navigate to any webpage on any device on my network while uploading then I get the full array of connection errors.

I assume this is happening because in order to navigate to a webpage you need to upload your page request to the web server and since I'm uploading a video to YouTube it is using up all of my upload bandwidth.

However if I'm downloading something at full speed and then start to download something else, then the speed will balance out so that both things can download at the same time. Is there some reason this doesn't work in the upload bandwidth or is there something else causing my problems?

The reported duplicate doesn't ask the same question, while the answer could technically apply to my question it doesn't meet my expectations for an answer for the question I have posed bandwidth control during youtube upload

The other purported duplicate Should uploading a file on DSL kill the download speed? answers the title of my post but not my main question which I will rephrase: If a webserver can handle my device downlading multiple things from it at once, then why can't my device handle uploading multiple things to a webserver at once? How are the two any different?

  • Possible duplicate of bandwidth control during youtube upload – DavidPostill Feb 18 '16 at 21:04
  • 1
    It should share minimal of what is needed to load a webpage during the time when you're uploading a video. You might want to review setting of your router, or connect directly to your modem to confirm it's devices inbetween your internet & devices that are causing it. – Lex Feb 18 '16 at 21:08
  • 3
    Possible duplicate of Should uploading a file on DSL kill the download speed? – MC10 Feb 18 '16 at 21:29
  • 2
    Missing details: Operating system, your browser, have you tried another browser, exact errors, maximum line-speed in both directions, the router, the ISP. – harrymc Feb 22 '16 at 6:29
  • 1
    The answer is really quite simple: Your router sucks. It’s not doing proper congestion control. Unfortunately, that’s the case with many consumer-grade routers. – Daniel B Feb 22 '16 at 16:15
5
+200

Assuming full array of connection errors means partially loaded/infinitely loading web pages and/or packet loss:

In most countries DSLs are asymmetrical: your upload bandwidth is smaller (usually 10%) compared to your download bandwidth. What this means is that it's exponentially easier to saturate your uplink if there are no fully functional QoS systems in place to balance the connection and avoid saturation, specially if they don't take overhead data into calculation.

You could be facing two problems, maybe simultaneously: faulty QoS system(s) or bufferbloat. There are many layers where the bandwidth is managed and, consequently, problems could be introduced:

  1. The end user application (e.g. a web browser or a P2P file sharing program).
  2. A software firewall (usually part of security suites).
  3. Your OS (On Windows 10 and 7, to check if the QoS service is activated go to ncpa.cpl > your adapter > properties > QoS Packet Scheduler).
  4. Your router (you'll have to check the manual for your specific model, or the sticker under it, but you can usually access its configuration through your browser by going to the default gateway address, which is usually 192.168.1.1 but you can confirm with a 'ipconfig /all' on the command prompt).
  5. Your modem, implying your modem and your router are separate devices (a correctly configured modem in this case should be on bridge mode and shouldn't apply any QoS rules, leaving it up to the router to manage the connection. Again, reach for a manual or ask online).
  6. Your ISP. Many ISPs throttle torrent traffic but I have never heard of ISPs throttling downlink when uploading files. As another user commented, this probably isn't an issue with the ISP but if nothing else solves it you could give them a call.
  7. The webserver (included just for completeness sake but probably unrelated to your issue, unless you were having exclusive problems browsing YouTube while uploading a video to it).

If a webserver can handle my device downlading multiple things from it at once, then why can't my device handle uploading multiple things to a webserver at once? How are the two any different?

Because the webserver that is providing you data is correctly configured to balance the output while your home network is failing on layers 1 to 5 above.

You'll have to troubleshoot as you haven't provided enough data to confirm where the problem is at. Here is my recommended process, assuming you have a router, a discrete modem and your internet connection is PPPoE:

Set-up:

  1. Remove the router from your home network and connect your device directly to the modem with an Ethernet cable.
  2. Make sure the modem is configured on 'bridge' mode. Additionally, check if the NAT, built-in firewall and the DHCP server are turned off.
  3. Set up the PPPoE connection directly under your OS (this tutorial might interest you if you don't know how to do it).
  4. Temporarily disable any software firewalls you might have installed (including the default one provided by Windows).

Try uploading something to YouTube again and see if the problem persists. If it doesn't, there's a problem with your firewalls or your router. You could try updating its firmware or flashing OpenWRT on it. If the problem persists, try those:

  • Run this speedtest check from DSLReports. Note down your idle latencies and maximum download and upload speeds. While uploading and downloading, also write down your bufferfloat values. If your idle latencies are higher than 200ms, there's something wrong with your ISP or your home network. If your idle latencies are OK but the bufferfloat latencies are too high (way higher than 250ms) this confirms bandwidth saturation while transferring data, which can be fixed by limiting throughput on your applications and/or with adequate QoS packet scheduling systems.

  • Try uploading large amounts of data somewhere else. Check if page loading still hangs. If it doesn't, there's something inherently wrong with your browser and/or with YouTube. If it does, you just need to find a way to limit your upload speed.

  • I'm not aware of any YouTube settings or Firefox/Chrome extensions to limit your uplink, but you can try with an external program such as NetLimiter throttling Chrome's upload while browsing with another program such as Firefox. Set the upload limit to 60% of your upload bandwidth as measured on the DSLReports test above. Otherwise, run the test below:

  • Download a torrent client such as Deluge. Unlimit the upload speed and force outgoing and incoming encryption. Randomize the connection port. Have a friend outside your LAN do the same. Grab a large file (e.g. a Linux distro .iso), make a .torrent and give it to your friend. Start uploading data to him and check if your upload speeds are constantly hitting your maximum uplink bandwidth as measured on the test above. Try browsing a page online, the problem should persist. Limit your upload speed to 60% of your maximum upload speed as measured on the test above. Try browsing a web page and see if the problem persists: it shouldn't. This just confirms the theory of bandwidth saturation if there is no management in place.

Report back your results.

  • I appreciate the thorough, thoughtful, respectful response. I'll probably just end up running net limiter and calling it a day. – user1886419 Feb 23 '16 at 15:56
  • @user1886419 I'd suggest flashing OpenWRT on your router and setting up qos-scripts on it – André Carini Feb 24 '16 at 0:51
  • 2
    I know this is an older post, but I had a similar problem and disabling QoS on Windows 10 worked for me. I think it was treating a YouTube upload like a stream, so it was prioritizing it over all other traffic. – KC McLaughlin Sep 17 '16 at 4:23
1

Sounds to me to be one of two options.

1) Your ISP is throttling your connection when you are trying to upload.

Or...

2) Your modem may be getting overloaded / too hot.

Test to see if it is Number One that is causing you problems, try this: Using Firefox, get this add-on => Firefox Throttle 1.1.6 or straight from their FTP site => ftp:// ftp.mozilla.org/pub/mozilla.org/addons/5917/firefox_throttle-1.1.6-fx-win.xpi

You can set the speed on how much you UPLOAD and how much you DOWNLOAD.

SOURCE This Youtube Video

If your problem is Number Two. Then you need to get another modem.

0

You're missing a lot of information from your post so we can't exactly pinpoint the problem on your network. In most scenarios, the download speed of your network is faster than your upload speed. Most have a 8x4 modem today (8 downstream and 4 upstream) meaning that their download speed can cap out higher than their upload speed (More information: http://www.cox.com/residential/support/internet/article.cox?articleId=d0168860-e4eb-11e0-dee8-000000000000). I'm thinking in your situation that you're maxing out your total bandwidth while uploading, making the rest of your network completely inaccessible to the Internet.

To fix this issue, I suggest trying to get a Internet package from your ISP with a faster upload speed and ask what the max bandwidth amount is for that package,

  • 2
    There’s no guarantee the upload wouldn’t saturate any consumer-grade upload bandwidth. Also, this is problem not specific to cable connections or even to asymmetric connections in general. – Daniel B Feb 22 '16 at 16:12
  • I want to understand why a webserver can max out upload bandwidth to multiple people but I cannont – user1886419 Feb 22 '16 at 16:22
  • Webserver? Do you mean your Internet connection? – Gabe Zimbric Feb 22 '16 at 17:18
  • @GabeZimbric nope – user1886419 Feb 23 '16 at 15:51
0

Since there are multiple variables associated here, I would do a few basic tests to gather more information and try to get a starting point.

  1. Do you see this behavior when you try the entire setup on a different device?

  2. While uploading on the device that you are currently using, when you navigate to another page and get connection errors, try using another device (such as your phone) to access a web page as well. Do you get a connection error on another device when one device is in the process of uploading? (If you are using your phone or a tablet as the other device, make sure to turn of cellular data on it)

(note the difference between the test in #1 and #2)

  1. Please perform the same test while connected using a LAN cable to your router and see if you face the same issue.

  2. (If possible) try to swap out the wireless router with a different one and see if this problem exists.

  3. Try performing an internet speed test using speedtest.net to determine your download and upload speeds. This will provide some insight for further troubleshooting.


Notes:

  • Make sure to do each of the above test independently so that the results can be properly evaluated.

  • If you notice any unexpected results, make sure you retest and the result is consistant.

0

Any half-decent Router should be more than capable of sharing bandwidth among competing connections, even when LAN/Wireless/WAN is saturated (whether downstream or upstream). Having said that, Wireless can be problematic especially at distance. Still, you should never see the kind of "blocking" behavior you're experiencing.

Your first port of call must be to upgrade your Router's firmware to the latest available version. If your setup includes a separate modem, you should upgrade the modem's firmware too.

If you see no improvement after upgrading firmware, then I'm afraid it's time for a new Router.

Note: Wireless has come a long, long way since the "n" standard. Do not settle for anything less than 802.11ac. Especially if you intend to use more than a couple wireless devices at the same time.

Note2: It is practically inconceivable that the ISP would be at fault here. The sharing of bandwidth among your devices is done at the Router, not the ISP. Even if upstream performance is poor, your Router should nevertheless share this "poor" bandwidth with all your devices. Things may be slow, but they should still work. All things considered, I'd put $ on your Router to be the problem.

0

My issue was at the first level of Silkerdax reply:

"1. The end user application (e.g. a web browser or a P2P file sharing program)."

I was originally using Google Chrome and as soon as I began an upload to Youtube (14gb file) my modem would crash before it even got to 1%. I tried using Internet Explorer (Windows 10) and it seems to be working fine now, currently at 6% and I am able to continue browsing.

My hardware: Modem - Motorola SB6141, Router - Asus RT-AC68U

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.