1

It started happening a few updates ago and I can't figure out if it's some setting that changed or if there's some reason it can't access the file. Has anyone else had this problem and been able to fix it?

I'd like to avoid a blanket uninstall/reinstall and actually figure out how to fix it so I can avoid it in the future.

The PC it's on is running Windows Vista Business x64 if that makes a difference. Winamp is version 5.572 (x86).

Update: I just checked and Winamp.m3u is getting saved properly on close, but not loaded properly on open.

Update #2: screenshots of playlist association settings:

enter image description here

enter image description here

enter image description here

4
  • 1
    I suppose a workaround would be to change my shortcut to: winamp.exe "%APPDATA%\Winamp\Winamp.m3u"
    – travis
    Feb 3, 2010 at 23:20
  • ...or just make a shortcut right to the Winamp.m3u, neither one is a perfect replacement for the normal behavior though.
    – travis
    Feb 3, 2010 at 23:27
  • Have you tried reinstalling Winamp? It might just do the trick.
    – alex
    Feb 11, 2010 at 19:45
  • @alex, yeah, I've reinstalled multiple times
    – travis
    Feb 11, 2010 at 22:06

2 Answers 2

1
+100

In the appdata\winamp directory, delete (or move out) all files with the extension .m3u8, as well as files with the .m3u extension. There may also be a folder called winamp.m3u8 which also need to be deleted. Do this while Winamp is closed. Now re-open Winamp, hopefully it will re-create the files and start working again.

Rationale: winamp.m3u is for legacy support. It actually attempts to load winamp.m3u8 on startup.

0
0

Go in Folder Options - File Types and make sure the .m3u files are opened by Winamp.

Let me know.

3
  • You can also check how to here: mydigitallife.info/2008/06/20/…
    – r0ca
    Feb 3, 2010 at 16:52
  • I added screenshots above to show my current settings.
    – travis
    Feb 3, 2010 at 17:30
  • huh... I'm kinda clueless now
    – r0ca
    Feb 3, 2010 at 17:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.