I recently installed Fedora 23 on my Windows PC, which is running Win 7 Prof 64 bit.

Before that I had a dual boot system with my above Win Sys and OpenSuse which was running after couple of minutes configuring the grub boot loader in yast.

So I created a bootable usb stick and installed fedora like my opensuse with a root-, home- and swap-partition and of course the mountpoint /boot/efi in the efi-partition on my /dev/sda1. (similar to opensuse-installation!)

The Installation was successful without errors and after the first reboot i tried to configure grub and the menu entries. But nothing helped and I'm trying since 2 days every solved forum answers.

for example:

Missing win7 entity

dual boot system using uefi

Rebooting after trying out the above shows up the new MenueEntry. Booting from this selection gives the following Error:

Missing Signature. You need to load the Kernel first.

After some tryouts to configure some grub menu entrys, booting fedora also threw an error message :

file 'boot/grub2/grubenv' not found  

hitting enter ignores the problem and still boots fedora though.

fDisk Output:

fdisk -l
Festplatte /dev/sda: 931,5 GiB, 1000204886016 Bytes, 1953525168 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: ADD7D9F2-CF60-40BF-AB36-440D08986EE4

Gerät          Anfang       Ende  Sektoren Größe Typ
/dev/sda1        2048     206847    204800   100M EFI-System
/dev/sda2      206848     468991    262144   128M Microsoft reserviert
/dev/sda3      468992  717268991 716800000 341,8G Microsoft Basisdaten
/dev/sda4   717268992 1434068991 716800000 341,8G Microsoft Basisdaten
/dev/sda5  1434068992 1748721663 314652672   150G Microsoft Basisdaten
/dev/sda6  1748721664 1748725759      4096     2M BIOS boot
/dev/sda7  1748725760 1951543295 202817536  96,7G Linux LVM

Festplatte /dev/sdb: 238,5 GiB, 256060514304 Bytes, 500118192 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: 6407EE3B-8043-4E6D-A844-C553572E4C46

Gerät      Anfang      Ende  Sektoren Größe Typ
/dev/sdb1    2048    264191    262144   128M Microsoft reserviert
/dev/sdb2  264192 481243135 480978944 229,4G Microsoft Basisdaten

Festplatte /dev/mapper/fedora-root: 23,3 GiB, 25002246144 Bytes, 48832512 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes

Festplatte /dev/mapper/fedora-swap: 12,9 GiB, 13828620288 Bytes, 27009024 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes

Festplatte /dev/mapper/fedora-home: 60,6 GiB, 65003323392 Bytes, 126959616 Sektoren
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes

other outputs of

lsblk // blkid | grep -i efi // grep -i efi /etc/fstab //
gdisk -l /dev/sdb // ls -l /boot/efi/EFI/ //
grub2-mkconfig /boot/efi/EFI/fedora/grub.cfg // ...

output of various relating commands

Thanks for your help in advance!

1 Answer 1


Your GRUB configuration is using BIOS syntax to try to boot Windows. This won't work on an EFI-mode installation, which you seem to have. Broadly speaking, you have two options:

  • Fix the GRUB configuration -- Tools like GRUB Customizer are supposed to help with this, although I have no experience with this program, so I can't help beyond pointing you to it. You can tweak it manually, too, as described (among other places) here.
  • Switch boot loaders -- About half a dozen EFI boot loaders for Linux exist, so you can switch away from GRUB 2 if it's not working for you. See this page of mine for my detailed thoughts on them. My own rEFInd is likely to be the easiest to install and switch to, should you decide to move from GRUB 2.

The biggest single advantage of GRUB 2 is that it's the default boot loader of most Linux distributions, including both Fedora and OpenSUSE. Thus, these distributions' maintainers put a lot of effort into creating a working configuration. The trouble is that GRUB 2's configuration is rather complex, so when the distribution maintainers' efforts fail, it can be a challenge to fix the problem. You'll have to decide for yourself whether to accept that challenge or to "abandon ship" to something else.

  • Thanks for your answer! :) In the meantime we ended up removing fedora, and after several hopless reboots somehow rEFInd showed up, allowing us to start into Windows. Unfortunately we saw many old Options too as Ubuntu, Fedora and so on. Now what would be the best settings / approach to make a clean install of Fedora on a new Partition, maybe also removing old EFI entities .
    – Yesyoor
    Commented Feb 20, 2016 at 1:32
  • wow I just realize who I am talking to :D Its like the best match of possible answer ! We were really lost and your program just saved it after some reboots where we couldn't do anything. It showed up after deleting the Fedora Partition with Grub. Thanks already so far ;) now how we clean up the /efi/EFI/boot directory? (there are 5 entities for openSuse and Fedora still left)
    – Yesyoor
    Commented Feb 20, 2016 at 1:40
  • If you're no longer using an OS, you can remove its directory on the EFI System Partition (ESP) -- /dev/sda1 in your case. If you want to leave a boot loader in place but remove it from the rEFInd menu, you can do so with the dont_scan_files, dont_scan_dirs, or possibly dont_scan_volumes options in refind.conf, as noted [in the rEFInd documentation.](file:///home/rodsmith/homepage/refind/configfile.html#hiding)
    – Rod Smith
    Commented Feb 20, 2016 at 15:58
  • no we actually want to keep the windows and the newly set up fedora(23) and now simply delete all eralier boot entities/loader etc that were found my refind earlier. But unfortunatly refind was deleted with the wipe and now installing it gives me an error : pastebin.com/Fs8Xzp1v
    – Yesyoor
    Commented Feb 20, 2016 at 19:21
  • We are messing around since two days now trying to config grub.The only time it really showed all the applied stuff was when refind saved us and let us boot back to windows ( after first day trying to set up grub) so we made a new install of fedora and tried out grub again. Now we feel the refinde solution would be great, but we cant get it to override the fedora grub stuff. At some point yesterday grub only showed up after rebooting and interrupting the reboot process by calling bios. So we only made it worse. If you can help us disable grub,leaving it to refind it would be really great!
    – Yesyoor
    Commented Feb 20, 2016 at 19:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .