0

I took the working IDE system drive out of an old Mac G3 system and I'd like to read its files on a Windows 10 OS. I have the Ext2Fsd driver and volume manager installed on my Windows system, which I've used to read Ext2 and Ext3 drives before, but it doesn't show this disk at all. However, the BIOS does see it. Is it possible the file system is something other than Ext2 or Ext3? If so, how do I find out what it is? I've also got a virtual Hackintosh OS installed on my VMware virtual machine but it doesn't recognize the drive either (connected through a USB converter). I've also got a virtual Ubuntu Linux machine but I haven't tried that yet. Any suggestions would be appreciated. Thanks, Ray

0

I can't remember if the old macs used a different format but the current macs use

OSX Extended (Journaled)

for primary partitions (where the OS is) to my knowledge Windows can not see a OS X partition, I believe that Linux can see it and interact with it. Why your VM can't see the HDD I am not sure, there are too many variables there to tell without seeing how it's set up, my first thought was if the addons CD has been inserted and ran(if your program has one), Try Oracle Virtual Machine. That's what I run all my VMs in and never have a problem. The other idea is that the drive may be encrypted, in that case you will definitely have to use OS X, as I couldn't find a way to open a G4 HDD that was encrypted any other way.

0

Mac systems typically use a different file system - HFS - which explains why you can't easly read it. Linux has some support for that filesystem - you will need to "apt-get install hfsprogs", then "mount -t hfsplus ....." to read the disk.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.