1

I have a Ubuntu 15.10 based PC with two different ATI/AMD graphics cards (ATI Radeon 4650 and AMD 7970) I want to install Windows via qemu/kvm with vga passthrough. For this I have to blacklist the AMD 7970 card using the command blacklist radeon. Unfortnately the radeon driver ist used for both cards, so I am afraid of blacklisting both cards. What coudl I do to circumvent this problem.

thanks in advance.

1

One solution would be to let EITHER vfio-pci OR pci-stub (depends on whether you use the newer -device vfio-pci or older -device pci-assign) bind the card for passthrough first.

Depends on whether you load either of the modules and/or radeon in the initramfs, you might need to use a softdep in /etc/modprobe.d to make sure radeon is loaded later than the passthrough module. (Like if you load vfio-pci in the initramfs but not radeon, you don't need the softdep. If you load both vfio-pci and radeon in the initramfs OR both NOT in the initramfs, you probably need the softdep.

For example:

/etc/modules-load.d/vfio-pci.conf:

vfio-pci

/etc/modprobe.d/radeon.conf:

softdep radeon pre: vfio-pci

/etc/modprobe.d/vfio-pci.conf:

options vfio-pci ids=XXXX:XXXX

The "ids" can be checked by lspci -nn. You may want to add the id of the HDMI Audio device of that card as well. The list is comma-separated (i.e. ids=XXXX:XXXX,YYYY:YYYY)

Btw, as long as you've done this correctly, you don't need to manually re-bind driver with sysfs/echo afterwards.

  • Thank you very much for your fast response. I will try this tomorrow! – stormborn234 Feb 20 '16 at 17:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.