1

I try to put the camera pictures (external ip camera) to a raspberry pi that I added to my network. The OS is Raspbian and I mounted a usb stick 16G for the pictures.

The problem is that I provided the camera the correct settings (check screenshot), but instead of putting the pictures on the usb stick, it just creates the path in my home folder. What do I forget? Thanks.

Some additional info:

Partial output of fdisk command:

Device     Boot Start      End  Sectors  Size Id Type
/dev/sda1  *     8064 31240703 31232640 14.9G  c W95 FAT32 (LBA)

Folder user, group and permissions:

drwxr-xr-x 3 pi pi 4096 Feb 21 14:28 FTP

image

  • I'd assume this is a problem with your FTP server, rather than the IP Camera. Check the home directory for your FTP server config for this user is on the USB stick. – Jonno Feb 21 '16 at 17:22
  • Have you checked that you can open this FTP location from another device on the network? Have you checked it from another program (ftp, curl or a browser) on the pi? Where is the home directory in which the snaps are created? Could you link from this to the pi's USB? – AFH Feb 21 '16 at 17:28
  • Jonno, AFH, I checked my user 'Pi'. He is in the passwd list and has a home directory. Everything seems normal. The home directory where the snaps are created is: /home/pi/mnt/usb1/FTP/. But that is not what I want. I want the snaps going to /mnt/usb1/FTP. If they go to /home/pi/mnt/usb/FTP the fill my flash card with Raspian on it and with limited place. If they go to /mnt/usb1/FTP then the pics are on the usb stick with 16G storage. – maxim Feb 21 '16 at 18:43
  • Ok I checked the folder permissions of my usb in /media and in /mnt. Both have user:pi and group:pi. So that should be ok. I admit in /media it was not the case. Tested again but here also it creates by itself a folder under /home/pi/mnt/usb1 and stores the pics under that folder. It's not on the usb that I mounted on /mnt/usb1... – maxim Feb 21 '16 at 19:15
0

Problem solved. A friend told me to create a new user/group for the ftp service and map the home dir of this new user to the usb stick. That's what I did and it works. I also 'chown' and 'chgrp' recursively the mounted map of the usb stick to the new user and group that I created. But this last action was only possible after formatting the usb stick in ext4 because it seems you can't change the owner and group of a stick formatted in FAT32. Now,... the path is created in the correct place... but my snapshots are still not there though. I think that is another issue. Not related to this one. I'll look further why my pics are not coming through. If needed I'll open a new threath with more info.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.