0

I get "untrusted certificate" errors when opening all https sites in IE 11.

I added sites to trusted sites, adjusted date and time, reset IE setting, installed sites' certificates (by click on view certificates and then install) but the problem still exists!

When I open up IE and want to open a site IE always shows "There is a problem with this website’s security certificate" after clicking "continue to the website .." always a red error appears on address bar like the following image:

http://i.stack.imgur.com/uHAKc.png

How do I resolve this?

2

I guess you are in a corporate environment where the proxy acts as SSL in the middle. Connections from the client to the proxy are encrypted, albeit with a proxy SSL certificate. And connections from the proxy to the target site are encrypted with the target's site certificate.

The advantage is that your proxy can perform anti-virus scans and check the content for malicious code.

You sometimes see this happening in third-party firewall solutions on clients, where the third-party software will act like a corporate proxy.

No protection without loss of privacy.

1

This is probably some legal or illegal man in the middle attack against your computer. Legal SSL interceptions are typically done in company networks or by Antivirus products. But also adware like Superfish or other malware will do such attacks or it might be that your router is compromised.

  • Thanks Steffen, error persists even by disabling Antivirus and firewall. I don't have problem with Firefox browser so I think it's not related to Antivirus or firewall. – Sarah Feb 23 '16 at 17:46
0

If this is not malware or a misconfigured anti-virus product then it is almost certainly a hardware firewall or web filtering device that's acting as a proxy.

The device in question will have a self-signed/issued certificate that will need to be imported in to the trusted root certificate store of your local computer.

I assume this is corporate device/network so I would speak to your IT department or whomever manages the network.

  • Thanks Samuel, I disabled antivirus and firewall but problem still persists. – Sarah Feb 23 '16 at 17:41
  • I imported certificate to both trusted root certificate and trusted publisher on local computer (through mmc command), but error still exists. – Sarah Feb 23 '16 at 17:52
0

This problem occurs when your corporate proxy does not have the correct or up to date certificate authorities installed. Without knowing more on your particular corporate network I can't advise on how to update these.

There is a work around in that Firefox does not use the system CA's but comes with it's own.

0

Refer to this discussion for a more accurate answer of why this happens.

Continually getting https Certificate Errors on all browsers

I got certificate error in all the browsers I used.

What fixed the problem


After reading the link, I learnt that these errors are due to disabled 'Automatic certificate root update'.

Fixing it in the registry solved the problem.

Type 'regedit' in Run. In the registry editor, navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\SystemCertificates\AuthRoot Set 'DisableRootAutoUpdate' value to 0. Reboot the system. the certificate errors disappeared.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.