3

I am having issues with input in VMware Workstation Player 12 in windowed mode or on multiple screens. When typing something in the VM and moving mouse cursor out of the VM without clicking on anything (for example on the second screen with host OS), the typing in that VM stops until I move the cursor back into VM.

Can this feature be disabled somehow so I am able to type in the virtual machine even when cursor is outside of it?

Both guest and host are Win10 x64 OS.

3

Technically you can, but practically not really.

When you move the mouse cursor out of the guest screen, you're ungrabbing (releasing input) from the VM. The whole point of moving the mouse cursor out of the VM is to tell it that you no longer wish to direct input to the VM. Imagine if you could move the mouse cursor out but that the VM still took keyboard input: you'd move the mouse cursor out, click on some other window, start typing, and then keys would go to the VM, not to the window you had just clicked on. That sounds incredibly confusing. (And if you don't intend to click on another window, then why do you want to move the mouse cursor out of the VM?)

That said, you could attach a second USB keyboard to your host and then connect that as a USB device to the VM, and then your VM would have its own dedicated keyboard. (Note that doing this requires setting:

usb.generic.allowHID = "TRUE"
usb.generic.allowLastHID = "TRUE"

in the VM's .vmx file first so that USB keyboards and mice are treated like generic USB devices. See https://kb.vmware.com/kb/1033435 for more details.)


Now, maybe you don't actually want to move the mouse cursor out of the VM. Maybe you just want it to be out of the way and are trying to move it to the corner of the screen, but you're accidentally moving it out of the VM. If that's the case, then in Workstation you can avoid that by going to Edit > Preferences > Input > Cursor and unchecking "Automatically grab and ungrab the mouse". Player doesn't provide UI to change this preference, but Player uses the same preferences file, so you can manually edit the preferences file (%APPDATA%\VMware\preferences.ini on a Windows host, ~/.vmware/preferences on Linux) by closing all Player instances and adding the line:

pref.motionUngrab = "FALSE"

Or, if you just want keyboard input to automatically go into the guest as long as the VMware Workstation or Player window has focus, regardless of where the mouse is, you can enable grab-on-keypress. Note, however, that this will automatically move the mouse cursor back into the guest since, from the guest's perspective, it needs to be somewhere onscreen.

15
  • Yes the fact is that I always end up accidentally moving mouse out of VM window when typing for example my passwords where I have numeric digits in it, ending up with writing just the part of the password until I move the mouse to get space for my hand to write on NumPad :) Unfortunately, I cannot find mentioned option Edit > Preferences > Input > Cursor in VMware Workstation 12 Player. Maybe it was available in older versions, but in this one it isn't? – IkkieCZ Mar 3 '16 at 9:10
  • Sorry, I didn't realize that you were using Player and not Workstation. In that case, you'll have to edit the preferences file yourself: Quit Player, open %APPDATA%\VMware\preferences.ini in a text editor, and add a line: pref.motionUngrab = "FALSE". – jamesdlin Mar 3 '16 at 11:18
  • 2
    I'd love it if there was the option to be able to move the mouse out of the VMWare window and still have keyboard input directed to the VM, until I clicked on something in the host. This is just how everything else works in Windows, I can type in a window even if I move the mouse away, until I clicked on some other window. – Gazihan Alankus Aug 24 '16 at 9:54
  • 1
    @gazialankus Can you explain why you want to move the mouse cursor out of the guest window? Note you could have keyboard input automatically go to the VM with the mouse cursor out of the window if you enable grab-on-keypress. – jamesdlin Aug 24 '16 at 10:14
  • 1
    When I move the mouse on another monitor, then press a key, the key press goes to the guest as expected, but the mouse come back right in the middle of the screen on the guest. I would like multi-monitor VM to be as intuitive as any modern OS would be – Bilow Jul 30 '18 at 12:40
-1

When I tried setting everything, I could not type in other windows on a multi monitor setup. VMWare was grabbing keyboard input always. It did not seem to do anything with the keystrokes though.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.