0

I'm using a 2012 MacBook Pro and I've just upgraded to Yosemite (10.10.5).  Unfortunately, most upgrades in Mac tend to interfere with some key programs that rely on gfortran.  Usually, this is easily resolved by uninstalling and re-installing gfortran.  I've done this using the following command:

sudo rm -r /usr/local/gfortran /usr/local/bin/gfortran

I initially installed the 5.2 version but removed it (as it didn't resolve my problem) and then tried to install gfortran 4.5.0.

However, I'm unable to install any more versions of gfortran due to the following error:

GNU fortran compiler (gfortran) can't be installed on this disk. A newer version of this software already exists on the disk.

I've tried searching my Mac via finder to see if there are any gfortran components remaining.

Any ideas how to resolve this? I've read a few posts but none has been particularly helpful; and I've also searched the Internet.

0

I just wanted to mention that this problem has now been resolved. I managed to install gfortran 4.9.2 and this resolved the issue. An older version of gfortran was on my system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.