1

I created a profile with the next options

Connection:

  • Hostname: ftp.example.com
  • Connection Type: SFTP
  • Port: 22
  • Username: wwwexample
  • Password: ******
  • Ask for password: no

Authentication:

  • Try private key file authentication: yes
  • Try password key authentication: no
  • Try keyboard interactive authentication: no

  • Private key file: D:\WORK\EXAMPLE\KEYS\wwwexample.ppk

  • Passphrase: ************
  • Ask every time: no

When I try to connect, NppFTP just says connecting and then disconnected. I created the private key with Puttygen, the same key I use for Fillezilla with Pageant (which works).

  • 3
    Speculative idea: Maybe use PuTTYGen to convert that PPK file to the more widely-supported OpenSSH key format? – TOOGAM Feb 22 '16 at 16:18
  • You are right, I did what you said and it worked – mikl Feb 22 '16 at 16:49
2

Stolen from a comment by @TOOGAM

"Use PuTTYGen to convert that PPK file to the more widely-supported OpenSSH key format."

  1. Open the current SSH private key in PuTTYGen
  2. File menu "Conversion"
  3. Convert to OpenSSH (first option)
  4. Done.
| improve this answer | |
0

Use the *.pem file with this format:

-----BEGIN RSA PRIVATE KEY-----
56767567567jhfhfhfghfgghf5464bdf546/56//56565656566fghr656546546546546546546
..
..
-----END RSA PRIVATE KEY-----
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.