0

After a restart recently, my computer wouldn't boot in to Windows 10. At the time I didn't have a Windows 10 installation media so I tried using boot tools on the Ultimate Boot CD to no avail. I now have the Windows 10 install and have booted from it then selected to repair my computer, then Startup Repair, however I get the following error on a blue screen:

Startup Repair
Startup Repair couldn't repair your PC
Press "Advanced options" to try other options to repair your PC or "Shut down" to turn off your PC.
Log file:
[ Shut down ]  [ Advanced options ]

Startup Repair couldn't repair your PC

When I boot with not boot CD I just see Loading operating system... but it freezes there. I have tried booting from Hirens boot cd off directly off the partition with Windows installed on it, but when I do that it gives me the message bootmgr is missing... press ctrl+alt+del to restart... or words to that effect.

What I think I've managed to do is delete/corrupt the boot manager, and possibly the MBR for disk with Windows installed on too - but my terminology and experience here may prove me wrong. My question is, how can I restore my boot data so I can boot in to Windows 10 again? Do let me know what other, specific information I can provide to help fill out the blanks.

Note: I booted in to PartedMagic from Hirons boot CD and I was able to successfully see the drives and partitions, including all the files. This looks like just boot data has been ruined.

Update: As pointed out in comments to Vassile's answer, I tried the /rebuildbcd, /fixmbr and /fixboot from the command prompt in a recovery console from the Windows 7 CD but trying this again with the Windows 10 recovery actually made it possible for me to use Hirens boot CD again with the "Boot Windows .. from hard drive" option and I'm finally back in to Windows! I still need to fix the missing boot manager, and my D: drive (a partition on the same drive as C:) is suddenly missing too, but I'm a step closer.

1

Try booting into a setup environment (or recovery environment, using a Windows Setup DVD) and press Shift+F10 to call up a command prompt, then use:

BootRec.exe /RebuildBCD
BootRec.exe /FixMBR
BootRec.exe /FixBoot

This can generally fix your MBR and rebuild a Boot Configuration (BCD) for your system. But it may not fix a damaged BootMgr and/or dual-booting configurations.

Update:

If you have BootMgr missing you could copy one from Windows Setup DVD (must match your Windows version and build) and place it at the root of Windows drive, see what happens. You should have access to startup repair and if it's still a no-go, run commands above and restart repair.

Note:

  1. Use a matching Windows Setup DVD. Windows 7 DVD may not work with Windows 10 install.
  2. BootMgr should be placed in Windows drive, not the hidden drive Windows created beforehand that has Boot and BCD in it.
5
  • I ought to have mentioned I did this with the Windows 7 recovery disk, however I did get a slightly different output with /RebuildBCD, insomuch that this one actually recognised there was an installation of Windows present, but still, it sticks on Loading Operating System ... on boot. – Leonard Challis Feb 22 '16 at 21:02
  • Aha! Although this didn't allow it to boot right off, it did enable me to use Hirens boot cd to select the "Load Windows ... from Hard drive" option and I'm now in Windows again! See my question for updates. – Leonard Challis Feb 22 '16 at 21:09
  • @LeonardChallis I don't know this Hirens system but make sure you place BootMgr in the right partition. Use Disk Management to mount all other partitions if you need to. Windows boots from C drive every time. So if you're not in your own Windows, (e.g. Using a recovery disk, etc.) your C, D, E, F drive may not be the one you think it is. – Vassile Feb 22 '16 at 21:25
  • Thanks Vassile - it didn't like it, but the fear of further problems has led me to backing up the files and wiping the disk to start fresh. But your answer helped me get to a point I could do that so thank you - I'll mark it as correct. – Leonard Challis Feb 23 '16 at 7:29
  • FixBoot gave me "Access is denied." Any ideas? – chris Mar 3 '18 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.