3

There are epic threads on the internet of users upgrading to Office 2016 and finding that Outlook 2016 email is no longer indexing. Windows Search logs the following error in Event Viewer:

The protocol handler Mapi16 cannot be loaded. Error description: (HRESULT : 0x80004005).

I've tried ALL the common suspects:

  • Rebuild Index
  • Reinstall Office
  • Remove and Re-add Outlook from Index Sources
  • Remove and Re-add Outlook Profile
  • We're already running Office 2016 x32

Removing Outlook from the index and using Unindexed search is acceptable as a very short term fix, but I need the "The protocol handler Mapi16 cannot be loaded." error fixed permanently.

At present this is happening on approx 50% of the workstations we upgrade to Office 2016 (Click-to-Run) and they're all running Win10 with all patches.

5
  • Possible answer here answers.microsoft.com/en-us/office/forum/office_2016-outlook/… "1. right click windows icon on the lower left 2.click "command prompt administrator" 3.type sfc /scannow then press enter 4.after the sfc type dism.exe /online /cleanup-image /restorehealth 5. Restart computer and test."
    – DavidPostill
    Feb 23, 2016 at 12:02
  • From the same link another possible answer" In Outlook 2016 Open File - Open Options - Open Search. Select "Indexing Options". Select "Advanced". Select "File Types". Scroll down to "pst" and highlight it by left clicking on it. Using the radio buttons change "how should this file be indexed" to "Index Properties and File Contents". Repeat for "ost". Filter descriptions should now read "Plain Text Filter". OK and Close out back to Outlook and after a while search should start to return proper results."
    – DavidPostill
    Feb 23, 2016 at 12:04
  • @DavidPostill There's nothing wrong with Windows, these computers have just been reimaged from scratch and search works on identical computers. Also, Indexing is not set to index PST files as text on the computers that search works on. I'd really rather fix the MAPI16 cannot be loaded error rather than a hacky fix.
    – Dom
    Feb 24, 2016 at 3:41
  • @DavidPostill That smacks of the standard Microsoft forums approach to everything which is running SFC and if that doesn't work, reinstalling.
    – Alan B
    Aug 3, 2017 at 11:10
  • @AlanB {shrug} It's also true that the repair approach fixes many obscure Windows problems
    – DavidPostill
    Aug 3, 2017 at 12:19

8 Answers 8

1

I've been struggling with the very same problem for the past few days.

It turns out it was related to the "HKCU\Software\Classes\VirtualStore" branch of the registry. It contained a few entries in the "MACHINE\SOFTWARE\Microsoft\Office\ClickToRun" subtree, so it was hiding the real "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun" subtree.

After removing the whole "HKCU\Software\Classes\VirtualStore\MACHINE" subtree and restarting the "Windows Search" service, the error disappeared and the indexing started working again.

This is the site that helped me in finding the solution : https://www.win-10-forum.de/office/87414-outlook-2016-office-365-betriebssystem-momentan-ausfuehren-anwendung-konfi.html

1
  • Thanks, tried this after the other suggestions failed. Renamed the MACHINE key to OLD_MACHINE rather than delete it, re-added Outlook to the index, and once it'd rebuilt the search was working again. Jul 4, 2019 at 14:00
0

Tentative Fix (just waiting for reproducibility).

Open Indexing Options and note the number of items in the index. Edit Environment Variables and add to the path:

x32 - C:\Program Files\Microsoft Office\root\Office16\

or x64 - C:\Program Files (x86)\Microsoft Office\root\Office16\

Reboot, Open Indexing Options, note the items in the index, Open Outlook, Indexer starts working on items.

Seems Indexer needs Office in the %Path% in order to open the required files for MAPI16.

Note: On machines where Office 2016 installs correctly, the above path variable is not required, so it doesn't really fix the issue properly, but it does solve the problem in a reasonable manner.

0

I had this same issue and turns out the cause was adobe pdf pro add in. The add in does not install with office 2016 however it was inherited with office 2013. Disabling the add in then unchecking outlook from advanced. close outlook. rebuild index, checking then allowed indexing to occur again.

0

I had the same problem and I was using Office 2016 Small Business that was preinstalled on my Dell laptop. I removed Office entirely via the control panel and after that I used the removal tool from support.office.com. After that, I renamed all folders named 'Outlook' or 'Office' in the AppData subfolder of my profile to make sure the new installation did not reuse them. I reinstalled Office 2016 x64 by downloading it from Office.com. Now all my e-mail is indexed.

0

This is what I got from a case from Microsoft; Adding the path (#4) was what worked for me. Win 10/64; Office 2016 Pro Plus /32

  1. Open file explorer -> C:\Windows\ProgramFiles

    • look for scanpst.exe.
    • Close outlook and run the tool
  2. https://support.office.com/en-us/article/Outlook-search-stops-working-after-updating-to-build-7870-2020-and-higher-0bcf0b06-320d-40c3-8cf0-7e3df90793ed?ui=en-US&rs=en-US&ad=US

  3. Check for Windows Updates

  4. On the affected machine

    1. Go to Start > System
    2. Click Advanced System Settings
    3. Go to Advanced tab > Environment Variables > System Variables
    4. From the list, select Path
    5. Click Edit
    6. Check to see if the location of the MAPI protocol handler (mapiph.dll) is there. By default, it will be C:\Program Files\Microsoft Office\Root\Office16, as shown below. Notice that you can find mapiph.dll in this folder. REBOOT.
    7. If not, add the path to the value, with a semicolon separated. And click OK to save the change.
  5. If only 1 users affected, please try to recreate the profile.

  6. Follow steps from this link https://blogs.technet.microsoft.com/csstwplatform/2010/07/29/desktop-search-event-3083-window-search-mapi2handler-1-cannot-be-loaded

Also, a tech had added Reg. Key: Computer\HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search DisableServerAssistedSearch DWORD value =1
I do not believe this was necessary, it seemed to be the path of the MAPI protocol handler (mapiph.dll) that resolved it. After a REBOOT.

0

Problem was Dixed December 2018 and occured again in January 2019 with Outlook 2016 version 1812. in Cache Mode

Extending path seems not to work for me, happend on Dell Image of Windows 10 updated to 1809 current Patchlevel as of 24.1.2019

What we figured out so far: Problem seems to happen in the Bridge between Windows Search x64 and Outlook mapi x32.

Quick Work Arround: Set Outlok Cache mode to not load all data, then you can search via Server by clicking on the search more line.

0
0

I had this problem on all brand new PCs (win10 20H2 x64). For initial setup I removed the preinstalled O365 (in diff languages) with the o15-ctrremove.diagcab, and here the problems starts:

1. In CONTROL PANEL a void "MAIL (OUTLOOK 2016)" icon
Delete the key

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{A0D4CD32-5D5D-4f72-BAAA-767A7AD6BAC5}

OK!

2. MAPI 16 (HRESULT : 0x8007007e)

Go to HKEY_CLASSES_ROOT\CLSID{F8E61EDD-EA25-484e-AC8A-7447F2AAE2A9}

and HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{F8E61EDD-EA25-484e-AC8A-7447F2AAE2A9}

and change the value

C:\Program Files\Microsoft Office\root\Office16\Interceptor.dll

with

C:\PROGRA~2\MICROS~2\Office16\MAPIPH.DLL

restart pc, now windows searh gives (HRESULT : 0x800700c1)

Delete the modified keys

HKEY_CLASSES_ROOT\CLSID{F8E61EDD-EA25-484e-AC8A-7447F2AAE2A9}

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID{F8E61EDD-EA25-484e-AC8A-7447F2AAE2A9}

Last: remove from windows search the wrong context.

Close outlook,

Restart the PC and voilà! Indexing running in al my PCs!

-1

installing 64 bit office solved this issue for me, i think it has to do with the windows search data file going above 2 GB which 32 bit office cannot handle.

[update 2017-04-06] just to clarify the issue seems to be with the windows search file in ProgramData\Microsoft\Search\Data\Applications\Windows, it seems that when this reaches 2 GB the indexing of emails on 32 bit office stops working. this also explains why when the search files are deleted search starts working again for a short period of time.

1
  • 1
    Except Outlook 2016 32-bit doesn't have a 2GB file limit.
    – Ramhound
    Apr 5, 2017 at 13:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.