1

I installed vsftpd on my Ubuntu 14.04 LTS Linux box. When I try to connect either locally using the URL ftp://localhost I do get an authentication dialog box. However, after I enter my user name and password the authentication box comes right back in an instant, asking me again for login details.

USE NOTES: I am definitely restarting the vsftpd service between tests using: sudo service vsftpd restart. Also, my use/security context is to provide an easy centralized file sharing repository for my local network. I have no desire to open the FTP server to the web or any other system but those stations on my local network that are behind the same, lone router.

If I try logging in from another station on the local network, using the latest version of FileZilla, I get a connection time-out error message. I think it's kind of working because if I try to connect using plain FTP (no SSL), I get a 530 error telling me that non-anonymous users must use SSL. But again, when I try to connect using SSL, I get the time-out.

I've got vsftpd setup using the settings from this link:

http://ubuntuforums.org/showthread.php?t=518293&p=3138955#post3138955

The ones I used are:

ssl_enable=YES
allow_anon_ssl=NO
force_local_data_ssl=YES
force_local_logins_ssl=YES
ssl_tlsv1=YES
ssl_sslv2=YES
ssl_sslv3=YES

And:

# Show hidden files and the "." and ".." folders.
# Useful to not write over hidden files:
force_dot_files=YES

# Hide the info about the owner (user and group) of the files.
# hide_ids=YES

# Connection limit for each IP:
max_per_ip=2

# Maximum number of clients:
max_clients=20

And I found this on a Linux forum, to set the root FTP directory:

# FTP root directory.
local_root=/home/roschler/Documents/ftproot

And I found this in a Linux forum post on vsftpd:

tcp_wrappers=YES

I had an allowed users list but I disabled it for now.

#userlist_deny=NO
#userlist_enable=YES
#userlist_file=/etc/vsftpd.allowed_users

When I look in /var/log/vsftpd.log I do see each connection attempt, both from localhost and from the remote station on the same network. What's odd is that I don't see any error messages. No connection failures, authentication failures, nothing. Just:

Tue Feb 23 21:44:52 2016 [pid 5325] CONNECT: Client 

Followed by the IP address.

But no luck so far logging in. Can anyone tell me how to get this working? Is it:

  • A firewall issue? If so, why do I get the 530 error message when I attempt to login remotely using non-SSL FTP?
  • A directory permissions issue, so vsftpd is failing internally when it tries to switch to the FTP directory?
  • What?
  • I know this is almost obvious but you only said "I enter my user name and password"; are those the couple for the Ubuntu 14.04 LTS system?. If sshd demon is up and you try to connect to the box via ssh are you successful? Did you try with sftp://localhost ? – Hastur Feb 24 '16 at 7:40
  • Does adding local_enable=YES, and log_ftp_protocol=YES, provide any more functionality/logging? – Castaglia Feb 26 '16 at 4:35
  • @Hastur I can connect via an SSH client using the user name and password. Some login details fail with vsftpd login. – Robert Oschler Feb 26 '16 at 5:06
  • @Castaglia Just tried that. No luck. No new information in log. – Robert Oschler Feb 26 '16 at 5:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.