0

I've been trying to install various versions of arch (Manjaro, architect...). All goes well except for a graphics problem. I've tried updating drivers, changing window managers...to no avail. Actually the only linux distro to work right is ubuntu, even fedora didn't work right. Here is what I'm seeing: graphics problems

text on windows is all screwed up, but text on websites for example looks fine. Any ideas?

1
  • I am using intel graphics with i915 driver in case that helps.
    – Silvertail
    Feb 24, 2016 at 16:55

2 Answers 2

0

Turns out deleting the video-intel driver with "sudo mhwd -r video-intel" solved the problem. My system still shows that it is running the video-intel driver, but I'm not too worried as long as it's working :)

0

For Arch, it may be the default acceleration method used by your intel driver (should be something like /etc/X11/xorg.conf.d/20-intel.conf).

The default is "sna". You might want to try changing it to "uxa" by adding the following line to the above configuration file: Option "AccelMethod" "uxa"

Source (a very useful page generally): https://wiki.archlinux.org/index.php/intel_graphics#SNA_issues

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.