5

We have two laptops - a Dell Latitude e5520 and a Dell Latitude e6520. In both cases they are able to connect to the wireless router without incident.

Here's my problem:

When I try to access the laptops' file-share from my workstation, sometimes I can access and sometimes the device cannot be detected on the network. Every time this happens I can still access the workstation's file-share from the laptop. So the access is one-way.

When the laptop starts up, connection works both ways. After awhile it becomes one-way (laptop to workstation only). I can get the connection correct again by disabling and enabling the adapter.

From my workstation, I can see the laptop inside of Network in Windows Explorer; but if I try to connect to it it says Windows cannot access \\mylaptop. So it is findable but not accessible.

If I plug in the ethernet cable then I have no problems, so the issue has to do with wireless.

  • I've gone into the power settings for the adapter and told windows not to power off the adapter in order to save power; but this does not solve the situation.
  • It's not a matter of signal strength either, because the wireless router is only one foot away...
  • The connection seems to last anywhere between 10 to 20 minutes. The laptop is not sleeping.
  • It can't be a matter of a loose chip connection because if I disconnect and reconnect to the wireless signal it always works.
  • It never loses the internet connection
  • It never loses the ability to browse shares on workstations on the network
  • I've updated the driver for the wireless adapter.
  • In the IPv4 settings for the adapter, I have Enable LMHOSTS lookup enabled for WINS, and the NetBIOS setting is set to Default.
  • I cannot ping the laptop from the workstation, but I can ping the workstation from the laptop - even with the firewall off, and even by ipaddress instead of computer-name. Destination Host unreachable

Here is the ipconfig /all from the laptop; it looks the same both before and after it loses it's fileshare connection (the ipconfig of the desktop basically looks the same except for the addresses and the adapter):

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : my.domain
   Description . . . . . . . . . . . : DW1501 Wireless-N WLAN Half-Mini Card
   Physical Address. . . . . . . . . : aa-bb-cc-dd-ee-ff
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.1.249(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.254.0
   Lease Obtained. . . . . . . . . . : Monday, February 29, 2016 9:57:53 AM
   Lease Expires . . . . . . . . . . : Tuesday, March 01, 2016 10:29:17 AM
   Default Gateway . . . . . . . . . : 192.168.1.1
   DHCP Server . . . . . . . . . . . : 192.168.1.13
   DNS Servers . . . . . . . . . . . : 192.168.1.12
                                       192.168.2.7
   Primary WINS Server . . . . . . . : 192.168.2.7
   Secondary WINS Server . . . . . . : 192.168.1.12
   NetBIOS over Tcpip. . . . . . . . : Enabled

Is there something else I can try?

[update]

So I hooked up WinMTR on my desktop to ping the laptop continually, and the laptop's fileshare seems to stay connected, even for hours and hours, whereas without the constant pinging it semi-disconnects after less than a minute. As long as the laptop is being continually pinged, it stays fully connected. But if I stop WinMTR for a few minutes, then it loses the connected and I can't ping it anymore (although it can ping other machines).

However, if I join the laptop with TeamViewer, something jives and the fileshare and the pings start working.

19
  • 1
    Can you access it by IP address, or do you get the same error? – Smeerpijp Feb 29 '16 at 15:54
  • oh, that's a good question... let me see... I have to start it and then wait for it to forget... I'll post back as soon as I have an answer. – bgmCoder Feb 29 '16 at 15:56
  • No, it can't be found that way, either. But it's the same as with using \\mycomputer - if I disconnect and reconnect to the wireless then it works for a time. – bgmCoder Feb 29 '16 at 16:30
  • First, see if it pings. Second, try turning off the firewall. – qasdfdsaq Feb 29 '16 at 17:17
  • No, I cannot ping the laptop from the workstation, but I can ping the workstation from the laptop - even with the firewall off, and even by ipaddress. Destination Host unreachable – bgmCoder Feb 29 '16 at 17:27
2
+100

You may be encountering a bad parameter in the Windows AutoDisconnect feature.

The last serious discussion on this subject by Microsoft that I found is in the article
How Autodisconnect Works in Windows NT and Windows 2000 (!) :

You can find the LAN Autodisconnect parameter in the registry under the subtree HKEY_LOCAL_MACHINE under the subkey:

\System\CurrentControlSet\Services\LanmanServer\Parameters

NOTE: The preceding entry must be located on the computer that has the share or shares.

The purpose is to disconnect idle sessions after a set number of minutes. The number of minutes can be set at a command prompt using the net config server command.

For example, to set the Autodisconnect value to 30 minutes, you would run the following command line:

net config server /autodisconnect:30

The valid value range is -1 to 65535 minutes at the command line. To disable Autodisconnect set it to -1.

Setting Autodisconnect to 0 does not turn it off and results in very fast disconnects, within a few seconds of idle time.

The registry does not allow you to add a -1 value. However, that modification may be made at the command prompt with the following command:

net config server /autodisconnect:-1

I do not really agree with the last paragraph above, since in my opinion setting the hexadecimal value of autodisconnect in the registry to ffffffff will have the same effect as the above command - avoiding disconnect for a few thousands years.

3
  • Is there any disadvantage to setting it to ffffffff like that other than a power drain? I don't know what was wrong before, the value was set to 15 which is the default. It just wasn't working. With this new setting everything works like a charm, though. – bgmCoder Mar 2 '16 at 19:15
  • I don't think there is any disadvantage when a network-share stays connected for a longer time, and Windows doesn't use more power for maintaining it in its runtime tables. Windows won't enter sleep while a file stays open over the network, but then you wouldn't want it to. – harrymc Mar 2 '16 at 19:31
  • Thanks for the help, Friend - I've had this problem for a long time and now it's resolved. – bgmCoder Mar 2 '16 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.