2

I'm trying to install Windows 8.1 in UEFI mode on my Mac Pro 4,1 flashed to 5,1 with 3.46GHz Intel W3690.

As far as I can tell, Windows will only create media that boots the way the box that creates the media is booted. If the box booted via BIOS/CSM, the media it creates will (only) install Windows in BIOS/CSM mode. If the box booted via UEFI, the media it creates will install Windows in UEFI mode. Maybe someone can correct me if that is not the case.

All the instructions I've found around the web for creating UEFI install media involve selecting UEFI mode in a PC's BIOS screen and creating the install media. Of course, Macs don't have that option.

Here's what I've done:

I initially ran into the fairly well documented "select the CD rom type issue", but worked around that by following the instructions here and I successfully created a Windows 8.1 DVD using a PC, an ISO downloaded from Microsoft, oscdimg and ImgBurn.

I installed Windows 8.1 and upgraded it to Windows 10. You'd think I'd be happy and move on, but I have to make things difficult. :p I want to be booting from (U)EFI, not BIOS/CSM.

I formatted the target drive as a GPT drive according to these instructions, but when I try to install to it, the Windows installer (booted in BIOS/CSM) tells me that it can't install to a GPT formatted drive.

I successfully hacked my Bootcamp Assistant Info.plist and have the option to create a USB drive to install Windows 7 or later using Bootcamp Assistant. BCA reports copying Windows files, downloads the Bootcamp files and then simply reports that the install could not be completed. o_O

However, the USB drive appears to have all the necessary files to install Windows, just not the bootcamp files. I have bootcamp files from a separate download and they installed without issue to the BIOS/CSM version previously mentioned.

No matter what method I use to create the USB - Bootcamp, Rufus on Windows or by manually building it Windows - the USB shows the now familiar blue windows for a few seconds, then goes to a big blue screen and tells me:

    Your PC needs to be repaired.

    An unexpected error occurred.

A needed file is missing or corrupted \Windows\system32\boot\winload.efi

    Error Code: 0xc0000001

    Use your install media to repair your PC or contact your Sys Admin...

My Mac Pro shuts down after 30 seconds or so.

I am very comfortable and well-versed in using the command line. I have Rod Smith's gdisk installed. I have XCode installed. I have Rufus and ImgBurn on the Windows side. I also have the Windows ADK, but I have not gotten into it because it seems to assume that you want to set up a network share to install Windows. If there's a way to create this media with that Windows tool, please provide detailed step-by-step instructions and remember that I cannot simply choose to boot in UEFI mode because my Motherboard does not have that option.

Cheers

3
  • You did try creating the USB drive with GPT partitions, right? Did you verify Setup starts on a regular PC? – Daniel B Feb 25 '16 at 19:06
  • Yes. The USB is GPT formatted, confirmed by OS X diskutil and gdisk. I don't have a regular PC. Setup does start from the USB when I'm booted into Windows from the BIOS/CSM installation. – iMattux Feb 25 '16 at 19:12
  • To whoever gave me the -1: I've done so much research. I linked to the pages that had what seemed to be the best methodologies. I read thru at least 10 sites that told me how to use Bootcamp. I read thru another 10 or so sites that told me how to use Rufus and/or Windows diskpart. I followed all instructions carefully. I'm able to create a DVD that boots and installs Windows in CSM mode. Every site I've seen other than the 2 linked above start by telling me to select UEFI from my BIOS... – iMattux Feb 25 '16 at 22:13
1

It turns out that it was in fact, quite simple, although I pieced it together based on information I found on the Microsoft website for Sys Admins.

The solution is to remove the bootmgr file from the root of the install USB. Note that the USB MUST be formatted as a single partition GPT disk in order to get a 4,1 or 5,1 Mac Pro to boot in UEFI mode. It may or may not work with other hardware that allows access to the EFI firmware, but if a Mac Pro finds an MBR, it boots in BIOS/CSM.

Furthermore, at least on my particular Mac Pro (as mentioned, a 2009 4,1 flashed to 5,1) it did not work when I formatted the USB drive using Apple's Disk Utility OR Gdisk - Sorry, Rod Smith. You are a legend and you have taught me much, but I had to use Windows diskpart to format the USB drive.

So, here is the exact step-by-step:

From any windows environment (I was booted in BIOS/CSM on my Mac Pro) open a command line prompt and type:

diskpart

list disk

sel disk *N* (where *N* is the number of your USB drive from the list)

clean

convert gpt

format quick fs=fat32 label="NAME"(where NAME is whatever you want to call your USB. Use quotes if you want to use a space, i.e. label="Windows 10")

exit

Then, still in Windows, I mounted the ISO I'd downloaded from MS and simply dragged everything EXCEPT the bootmgr executable to the root of the USB drive. Note that I did copy bootmgr.efi, just not bootmgr.exe.

Reboot holding alt/option, select the USB drive labeled "EFI Boot" and follow the instructions.

Per Stack Exchange policy, here's how I figured it out:

I ended up on this page. Where I found this quote in regard to booting in the desired mode, which is the EXACT problem I'm trying to solve:

If this is a frequent problem, you can remove the boot files for UEFI mode or BIOS mode to prevent the PC from booting in the wrong mode. If the PC firmware is set up to boot in the wrong mode, the media will immediately fail to boot, allowing you to immediately retry booting the PC into the correct mode.

Boot in UEFI mode: To prevent Windows PE from booting in BIOS mode, remove the bootmgr file on the root of the media.

Boot in BIOS mode: To prevent Windows PE from booting in UEFI mode, remove the efi folder on the root of the media.

They are talking about building custom Windows install media for deployment in a large organization, using the ADK and Windows PE, but I took at shot at this very simple solution and it worked for both Windows 8.1 and Windows 10.

1
  • Is there any way to force UEFI mode on an existing installation without adjusting the install media as described (and then wiping the drive and reinstalling Windows)? – tubedogg Jun 23 '19 at 6:00
0

There is no big philosophy about creating USB that is only UEFI bootable.

Let's start from Windows ISO. Mount it.

Then format whole USB with FAT32 (MBR style, single partition), NO active partition!

Then copy all files from ISO to USB.

If USB contains an \EFI folder then it is UEFI bootable.

If USB does not have an \EFI folder then it is NOT UEFI bootable.

\EFI folder should have two sub folders: \EFI\boot and EFI\Microsoft\boot with corresponding files.

If USB does not have an active partition then it is NOT BIOS bootable.

If you could write a protective MBR to USB then it would be ONLY UEFI bootable.

If media is booted UEFI way it will install UEFI bootable Windows 8.1/10 (e.g. expects GPT disk as target).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.