0

After launching SQL Server Management Studio 2012, the "Connect to Server" prompt is displayed. In the "Authentication" dropdown, it defaults to "SQL Server Authentication", which I have used in the past, however I'd like it to default to "Windows Authentication" now.

I've looked through every setting I can find in SSMS, but it doesn't seem to be configurable. I've also logged in using "Windows Authentication", however it doesn't remember this the next time I launch SSMS.

Any suggestions on how to make this work?

  • I'd probably start by renaming user\AppData\Roaming\SQL Server Management Studio to another name, and launching the program., – Frank Thomas Feb 25 '16 at 19:52
  • @FrankThomas Thanks for the suggestion. I found it at user\AppData\Roaming\Microsoft\SQL Server Management Studio, and renaming did cause a new folder with the original name to be created... though the situation remains unchanged. – user3071284 Feb 25 '16 at 20:49
  • then the information is likely in the registry, as it is a per-user configuration. – Frank Thomas Feb 25 '16 at 20:53
  • 1
    just out of curiosity, are you running SMSS as Admin? My recollection is that the Connection dialog should remember your last login, so if its losing that info, I wonder if running as admin might allow you to login once as a windows user, close the program, and then launch it again as a non-elevated user to see if it stuck. – Frank Thomas Feb 25 '16 at 20:55
  • Thanks @FrankThomas. The administrator workaround didn't do the trick. I also tried running as admin twice in a row to see if it stuck. Any idea where in the registry to look to delete the login information? – user3071284 Feb 25 '16 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.