since a couple of days the icloud drive seems to be "stuck". The symbol in the sidebar in finder doesn't go away (pie chart). It looks like it still sycning.

enter image description here

What can I do to find out at which files it is potentially stuck?

  • 1
    Have you tried to restart the machine?
    – Ramhound
    Feb 26, 2016 at 13:40
  • yes I have tried that (first thing ;))
    – Tino
    Feb 26, 2016 at 13:41
  • But as the OP asked, how do I find out which file is stuck? Or which files are stuck. Dec 20, 2019 at 18:53
  • 1
    I can’t post an answer because of my “bad reputation” (you would think my SO rep would count for something) but I have encountered this problem intermittently, including the pie progress indicator stuck at nearly complete. The trick for me this time was checking the Trash for stuck files. Permanently delete any file with a cloud icon next to it. I also recommend deleting any files that are copies of files that have not been deleted (i.e. duplicates of files still on the system, whether or not they have the same file name). Or just empty your Trash, if you’re into that sort of thing.
    – daxmacrog
    Nov 11, 2020 at 22:51
  • Other questions of this, ordered by number of votes: apple.stackexchange.com/q/264915/63255, apple.stackexchange.com/q/313716/63255, apple.stackexchange.com/q/293051/63255. Most successful resolutions seems to be killall bird, and if necessary first deleting ${HOME}/Library/Application Support/CloudDocs/.
    – Carl
    Apr 18, 2023 at 11:39

10 Answers 10


Go to the Terminal and type:

killall bird

Check if this fixes your issue. If not, go back to Terminal and type:

cd ~/Library/Application\ Support
rm -rf CloudDocs

Then immediately restart.

For 300gb of files, I had to wait an hour for anything to show up in the iCloud folder, and 4 hours for the sync to finish.

Source for this answer: here.

  • 24
    Just for anyone trying this: first, kill bird. Check to see if the problem is fixed. If it is, skip the remaining steps to save yourself a ton of time. Nov 14, 2019 at 20:40
  • 1
    When I do kill bird everything in the sidebar jumps its so funny Apr 6, 2021 at 15:01
  • This worked for me but it took a few minutes for the sync to get back up and running, meanwhile it just showed "0 MB of X MB". Oct 22, 2021 at 17:01
  • 3
    Worked for me! All I had to do was killall bird.
    – bill
    May 12, 2022 at 17:31
  • 1
    I had to rename the ~/Library/Application\ Support/CloudDocs from Finder to avoid a permission issue, but it worked.
    – Vincent J
    Apr 10, 2023 at 21:52

For me what worked is going into my Utilities, opening the Activity Monitor. Then look for a process called "bird" and force quit. No files deleted or moved, it just restarted the upload process.

  • 4
    On macOS Catalina here. Whatever the reason for it to get stuck, killing bird in Activity Monitor immediately fixed the issue for me. Nov 14, 2019 at 20:39
  • 1
    Catalina here. Killing Bird and it immediately restarts, but. Now the upload reads 0 of 374k bytes uploaded. Dec 20, 2019 at 17:56

I found that use of a VPN can both cause and cure the problem. Certainly turning on a VPN midway through an upload has stopped mine, but I also found that turning it on can cause a stalled upload to restart. Of course, it might just be my internet service provider messing with me.

  • 2
    It makes sense to me. I observed this problem after I was testing VPN connection. I wish I had tested your solution. I followed other's suggestion by unchecking "iCloud drive" and checking it back. It turned out to be a disaster.
    – nngeek
    Nov 26, 2019 at 1:49
  • The same case for me, turning off NordVPN fixed the issue. Jul 24, 2023 at 10:35

Under ~/Library/Application Support/, there's a folder called CloudDocs. Chances are this is the culprit. Delete it (or move it elsewhere) and iCloud will reset itself and stop looping and re-caching the same files over and over again.

  1. Manually go through all the iCloud Drive files via Finder and look for all files with a 'cloud' (not-yet-synced) icon and drag or copy those files to a location outside iCloud Drive. (Perhaps someone knows of an automated way to do step (1).) (Simply dragging the files out and back in might also solve the issue; didn't think to try that, so if anyone can test that … ;)
  2. In System Preferences:iCloud:options, uncheck the app(s) that had the 'cloud' files; alternatively uncheck iCloud Drive (in which case, iCloud Drive will reinitialize with all apps checked).
  3. Then check the option:app(s) (or iCloud Drive) to restart it.
  4. Move the files from (1) above back to their proper locations in iCloud Drive.
  • This seemed to work for me. I believe it happened when I closed my laptop mid-sync.
    – Neil
    Jan 20, 2017 at 16:41

I had same problem but found there was an old application buried w/in my Documents folder that was incompatible with Sierra (circle/slash through icon) so, for whatever reason, iCloud sync wouldn't move it. I "compressed" (read: zip’d) the problem app and deleted the original and now everything is peachy.

  • 1
    How have you found the problem application?
    – dmitry1100
    Oct 15, 2019 at 17:29

I had this issue with iCloud Drive not syncing iBooks. I found that using the touch command on the parent folder causes everything to be uploaded. Touch tells the OS that the files were modified, so it reuploads them. If you only have one or two files, just touch those.

Drag a file from that folder to the command line to see what the actual directory is.

Mine turned out to be

/Users/username/Library/Mobile\ Documents/iCloud\~com\~apple\~iBooks/Documents/

So I went to the parent directory, and "touched" the Documents folder.

cd /Users/username/Library/Mobile\ Documents/iCloud\~com\~apple\~iBooks/

touch Documents

Then, everything changed from "Waiting to Upload" to "Uploading".


I had the same problem, and found that relaunching Finder solved it for me. If someone else comes here with the same problem, I suggest they try relaunching Finder first, before moving on to more intense things like restarting the machine or other steps.


'In System Preferences:iCloud:options, uncheck the app(s) that had the 'cloud' files; alternatively uncheck iCloud Drive (in which case, iCloud Drive will reinitialize with all apps checked)'

When I try this, it warns me that files will be deleted permanently. I can see no files in my Documents folder on the hard drive; and most on iCloud drive are missing

  • This does not answer the author's question.
    – Ramhound
    Jan 23, 2017 at 20:05

I simply double-clicked on the cloud icon for those not updating on the iCloud drive. Just like that, they started updating correctly. You need to double click on each one, one at a time.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .