25

since a couple of days the icloud drive seems to be "stuck". The symbol in the sidebar in finder doesn't go away (pie chart). It looks like it still sycning.

enter image description here

What can I do to find out at which files it is potentially stuck?

  • Have you tried to restart the machine? – Ramhound Feb 26 '16 at 13:40
  • yes I have tried that (first thing ;)) – Tino Feb 26 '16 at 13:41
  • But as the OP asked, how do I find out which file is stuck? Or which files are stuck. – Harry McGovern Dec 20 '19 at 18:53

10 Answers 10

25

See the answer here. Briefly, you can go to the Terminal and type:

killall bird
cd ~/Library/Application\ Support
rm -rf CloudDocs

Then immediately restart. For 300gb of files, I had to wait an hour for anything to show up in the iCloud folder, and 4 hours for the sync to finish.

|improve this answer|||||
  • 3
    Just for anyone trying this: first, kill bird. Check to see if the problem is fixed. If it is, skip the remaining steps to save yourself a ton of time. – Jake Bathman Nov 14 '19 at 20:40
8

For me what worked is going into my Utilities, opening the Activity Monitor. Then look for a process called "bird" and force quit. No files deleted or moved, it just restarted the upload process.

|improve this answer|||||
  • 3
    On macOS Catalina here. Whatever the reason for it to get stuck, killing bird in Activity Monitor immediately fixed the issue for me. – Jake Bathman Nov 14 '19 at 20:39
  • Catalina here. Killing Bird and it immediately restarts, but. Now the upload reads 0 of 374k bytes uploaded. – Harry McGovern Dec 20 '19 at 17:56
5

I found that use of a VPN can both cause and cure the problem. Certainly turning on a VPN midway through an upload has stopped mine, but I also found that turning it on can cause a stalled upload to restart. Of course, it might just be my internet service provider messing with me.

|improve this answer|||||
  • It makes sense to me. I observed this problem after I was testing VPN connection. I wish I had tested your solution. I followed other's suggestion by unchecking "iCloud drive" and checking it back. It turned out to be a disaster. – nngeek Nov 26 '19 at 1:49
4

Under ~/Library/Application Support/, there's a folder called CloudDocs. Chances are this is the culprit. Delete it (or move it elsewhere) and iCloud will reset itself and stop looping and re-caching the same files over and over again.

|improve this answer|||||
1
  1. Manually go through all the iCloud Drive files via Finder and look for all files with a 'cloud' (not-yet-synced) icon and drag or copy those files to a location outside iCloud Drive. (Perhaps someone knows of an automated way to do step (1).) (Simply dragging the files out and back in might also solve the issue; didn't think to try that, so if anyone can test that … ;)
  2. In System Preferences:iCloud:options, uncheck the app(s) that had the 'cloud' files; alternatively uncheck iCloud Drive (in which case, iCloud Drive will reinitialize with all apps checked).
  3. Then check the option:app(s) (or iCloud Drive) to restart it.
  4. Move the files from (1) above back to their proper locations in iCloud Drive.
|improve this answer|||||
  • This seemed to work for me. I believe it happened when I closed my laptop mid-sync. – Neil Jan 20 '17 at 16:41
0

I had same problem but found there was an old application buried w/in my Documents folder that was incompatible with Sierra (circle/slash through icon) so, for whatever reason, iCloud sync wouldn't move it. I "compressed" (read: zip’d) the problem app and deleted the original and now everything is peachy.

|improve this answer|||||
  • How have you found the problem application? – C0DEF52 Oct 15 '19 at 17:29
0

I had this issue with iCloud Drive not syncing iBooks. I found that using the touch command on the parent folder causes everything to be uploaded. Touch tells the OS that the files were modified, so it reuploads them. If you only have one or two files, just touch those.

Drag a file from that folder to the command line to see what the actual directory is.

Mine turned out to be

/Users/username/Library/Mobile\ Documents/iCloud\~com\~apple\~iBooks/Documents/

So I went to the parent directory, and "touched" the Documents folder.

cd /Users/username/Library/Mobile\ Documents/iCloud\~com\~apple\~iBooks/

touch Documents

Then, everything changed from "Waiting to Upload" to "Uploading".

|improve this answer|||||
-1

I had the same problem, and found that relaunching Finder solved it for me. If someone else comes here with the same problem, I suggest they try relaunching Finder first, before moving on to more intense things like restarting the machine or other steps.

|improve this answer|||||
  • The user has already tried restarting the machine. How does your answer add anything to that? – Scott Dec 2 '16 at 5:37
-3

'In System Preferences:iCloud:options, uncheck the app(s) that had the 'cloud' files; alternatively uncheck iCloud Drive (in which case, iCloud Drive will reinitialize with all apps checked)'

When I try this, it warns me that files will be deleted permanently. I can see no files in my Documents folder on the hard drive; and most on iCloud drive are missing

|improve this answer|||||
  • This does not answer the author's question. – Ramhound Jan 23 '17 at 20:05
-3

I simply double-clicked on the cloud icon for those not updating on the iCloud drive. Just like that, they started updating correctly. You need to double click on each one, one at a time.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.