1

I'm not very familiar Linux and I would really appreciate a bit of help. I manage Windows servers and workstations. We have one Dell T7500 workstation which is running Red Hat 6.5. This workstation is changing hands and the new user requested to have Windows installed, but wanted to keep Linux. I discovered it had a Virtual Machine Manager in System Tools, so I set up a Windows 7 VM which works great.

I noticed Red Hat has a software update available so I ran it. It said there was a package conflict (due to being from different sources), so I canceled the update. The machine was running fine at this point. I decided to check the BIOS out to make sure virtualization support was enabled. It was, but Hyper-Threading was disabled. I could make changes because there was an Administrative password preventing me from doing so. I reset the password via the MB password reset jumper. This cleared the password. However, at this point I could no longer boot. I receive the error:

Kernel panic - not syncing: Attempted to kill init!

PID: 1, comm: init Not tainted 2.6.32-431.23.3.el6.x86_64 #1

Call Trace:

[< ffffffff815284fc >] ? panic+0xa7/0x16f

[< ffffffff81077332 >] ? do_exit+0x862/0x870

[< ffffffff8118a855 >] ? f put+0x25/0x30

[< ffffffff81077398 >] ? do_group_exit+0x58/0xd0

[< ffffffff81077427 >] ? sys_exit_group+0x17/0x20

[< ffffffff8100b072 >] ? system_call_fastpath+0x16/0x1b

I don't know if it was the software update conflict which did this, or removing the password in the BIOS. Thanks for you help.

1

There should be more error messages above the panic; my guess is that RH could not access the disk containing its root partition.

The Linux boot process usually starts with an initramfs image that contains a very minimal set of drivers (often generated for the specific system).

Many PCs have a BIOS setting for switching the drives between "AHCI" (native SATA) and "legacy" (emulated IDE) modes. If you reset the BIOS settings, it'll usually default to "legacy" mode, and it's possible that the initramfs only has drivers for SATA, not IDE/PATA.

Check the BIOS settings for any parameters like that.

| improve this answer | |
  • The password reset does not reset the BIOS settings. However, I switched from AHCI to ATA just to give it a try and receive the same error. – merlot Feb 26 '16 at 20:46
  • Just realized the change I made did nothing - the drive is running off a Dell SAS 6 Controller. – merlot Feb 26 '16 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.