1

I have Asus X200MA Notebook with Windows 8.1 64 Bit with UEFI mode enabled. On this notebook I find that the only way to enter the UEFI Setup is from within Windows 8.1 Change PC Settings (Restart to UEFI Setup) or pressing F2 only when Windows 8.1 is restarted. I have tried both ways Fast Boot Enabled as well as Disabled.

i.e. F2 key or DEL or Escape key is ineffective on Cold Boot. I raised this query to Asus Support but they suggested to check for normal working of F2 key or to update the Firmware.

I even tried powering on with F2 or DEL or Escape key already pressed but on Cold Boot laptop does not enter UEFI Setup.

Does anyone know if this is expected functionality on Asus laptops with Windows 8.1? Surprisingly even Asus Knowledge Base here refers to Windows 8 Change PC Settings option only and nothing about Cold Boot.

Thanks.

  • What happens if you shutdown with the shutdown -p -f and then try? I'm somewhat suspicious of some sort of fast/hybrid shutdown, even though you tried with it disabled. – Jonno Feb 27 '16 at 14:43
  • @Jonno - You are right. Thanks for this input. Even though Disabling Fast Boot in UEFI did not work, ( I checked again thinking did I forget to Save changes earlier..just in case) I am now able to enter UEFI Setup by pressing F2 on Cold Boot when laptop is shutdown using shutdown -p -f command! You may like to elaborate more if relevant and post it as an Answer. – patkim Feb 27 '16 at 16:00
2

It would appear the machine isn't managing to get to a fully shut down state, likely due to fast or hybrid shut down.

One way to test this is to use the command shutdown -p -f, which will force the machine to a full shutdown state.

To turn off Fast Startup, you can do the following:

  1. Press Win+X
  2. Go to Power Options (Alternatively, find this within the Control Panel, or the battery icon in the notification area.)
  3. Click Choose what the power buttons do in the side bar.
  4. Click Change settings that are currently unavailable, which should ask for administrative privileges.
  5. Uncheck Turn on fast startup

enter image description here

Your machine should now perform full shutdowns, instead of hybrid.

0

Some third-party boot managers, such as GRUB 2 (which is the default for many Linux distributions), gummiboot/systemd-boot, and rEFInd, provide a feature to reboot into the firmware setup utility. This feature is not always available, though, because it relies on support in the firmware itself, so if your firmware lacks that option, the feature will either be missing from the boot manager's menu or won't work. It may also be disabled by default; you must consult the boot manager's documentation for details.

Installing one of these boot managers merely to get a more reliable boot-to-setup-utility function is likely overkill. It might be helpful if you're desperate, though; and if you're using a dual-boot configuration, it's worth looking into this functionality, or maybe even change your boot manager so you can get it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.