2

I installed JS Hint Gutter recently for use on most of the Javascript projects that I work on. It works great. However I recently started work on a React project that uses JSX, which of course causes warnings to be raised by JS Hint Gutter.

I followed a guide from the Sublime Text Unofficial Documentation site on disabling packages so now I have a .sublime-project file in my project directory that looks like this:

{
    "settings":
    {
        "ignored_packages": 
        [
            "JSHint Gutter"
        ]
    }
}

The name that I used for JSHint Gutter was a guess based on the directory name it is stored in my Packages directory. I also tried Sublime-JSHint. Neither seemed to work because even after restarting Sublime I still get linting errors from JSHint Gutter.

How can I disable the JSHint Gutter package for this one single Sublime Text 3 project that I am working on? Is this question the same as how to get the exact name of a package to include in ignored_packages?

I also discovered that after installation the package directory contains a file package-metadata.json. It has keys like description but none like name that I could use to include in ignored_packages.

0

You must log in to answer this question.

Browse other questions tagged .