6

Windows 10 is unusably slow as soon as I try to do anything disk-based.

If I look at task manager I can see 100% disk usage for speeds as low as 0.2 MB/s.

What can I do to work out what's wrong and potentially fix it?

benchmark

atto

SSD: Sandisk U100 128GB in a 2012 Samsung 900x

I tried checking the Samsung site for firmware - it only listed packages for XP from 2011.

  • Can you get some software to read S.M.A.R.T information from the drive and report that ? I'm guessing the drive is failing. It could also conceivably be an issue with the BIOS or a corrupt filesystem. When did this start happening ? – davidgo Feb 28 '16 at 23:09
  • Is its write cache enabled? – Tom Yan Feb 29 '16 at 6:42
  • Did you run the Sandisk software for your SSD? – Tracy LF Mar 2 '16 at 14:41
  • @Geekomatic I did - it said that updates were managed by the OEM. – mackenir Mar 2 '16 at 21:26
8

This looks like a TRIM problem. It seems as if the drive isn't garbage collecting correctly, causing severely degraded performance during write operations.

  • Blocks in SSDs must be erased before they can be rewritten, and the drive can only erase them if it knows that they no longer have valid data. Hence, the TRIM command is provided so that the operating system can tell the drive what blocks can safely be erased. If TRIM is never sent to the drive, or if the drive doesn't support TRIM, it is eventually forced to erase blocks as they are rewritten, severely degrading performance (and reducing the life of the drive due to increased write amplification).

  • A tell-tale sign of this is the extraordinarily poor performance the drive exhibits with QD64 random writes. SSDs should always perform better at higher queue depths than at lower queue depths, but they also demand more resources from the SSD. With more concurrent random writes, the drive has to erase more blocks at a time. Less capable SSD controllers can choke in situations like this causing performance to fall off a cliff when multitasking.

  • Note that the SanDisk U100 has an SLC buffer which gives a short burst of high write performance before slowing down. The drive may have very slow performance once that buffer is exhausted. The ATTO benchmark is writing to only 256 MB, where the entire test file likely fits in buffer, while AS SSD is writing to 1 GB, which may not fit in the buffer. However, this alone likely does not explain the problem, as any half-decent SLC-buffered SSD should still be able to attain reasonable (even if slow) write performance should the buffer be exhausted.

  • I'd download CrystalDiskInfo and take a look at the SMART information to see if there's an issue with the SSD itself. You should also try running the Windows Storage Optimizer (formerly Disk Defragmenter) to explicitly trim free space on the drive. If this does not help, the drive is likely faulty and should probably be replaced.

1

Leaving my advice here cause it might help someone and it is one of the first results on google .

Was having problems with my SSD not being able to get speeds over 30 MB/s . Tried everything and it would randomly work properly and randomly(or so I thought) revert back to it's slow state . By the looks of things windows 10 is crap and whenever i set my computer to sleep my SSD goes in to slow mode (and from userbenchmark the splatting test for the GPU would get 0.1 fps and would not run /gtx 1050) . The reason I could not figure out when it would happen is because windows 10 has fast start enabled by default meaning that whenever i "turned off" my computer the problem would persist . Restarting the computer or performing a hard shut down solves the issue .

So the fix is turning off fast start (check how) and not to put you computer to sleep until Windows figures things out (although no crushing so probably oblivious to the whole issue) .

Also another thing I randomly get freezes . I do not know if it is related with the above issue , but the solution was to unplug and plug back in the power cable or the reverse depending what you are using at the time of the freeze (laptop here) .

Never post anything online but these problems had me really worried and were plaguing me for over 2 months so I hope it helps somebody .

PS still does it randomly without putting it to sleep bur restarting resolves the issue .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.