1

I recently upgraded to Windows 10 and I have a dual monitor set up. In the past, both screens shows the same desktop/taskbar and I can access the taskbar from either screen. Just recently I noticed large pieces of the taskbar on my secondary monitor are missing? The issue isn't necessarily that my taskbar isn't there, but more that it's only showing parts of it. If I hover my mouse over where the taskbar would be, I can still click and access different programs I have pinned to my taskbar. Has this happened before to anyone and were you able to fix it?

Here's a screenshot of my primary monitor: enter image description here

and here's a screenshot of my secondary monitor:enter image description here

you can see the second one only shows the Task View button and even then not the entire thing.

  • Is it possible for you to make a screenshot of the issue? It sounds like a non-standard problem. – LPChip Mar 1 '16 at 14:00
2

Right click the taskbar, click properties. There will be a section on the bottom third called 'Multiple displays'

Here you can customize how much of the taskbar appears on the secondary display.

The Default is: Show taskbar on all displays (checked)

Show Buttons on: All Taskbars

Buttons on other taskbars: Always combine, show labels.

| improve this answer | |
  • I checked this out and my task bar properties are set to default. I have "show taskbar on all displays" checked and show buttons set to "all taskbars". However my "buttons on other taskbars" option is set to "always combine, hide labels" and I don't have the option to "always combine, show labels". I don't think that's related to the issue at hand though... – Struggling Mar 1 '16 at 14:34
  • I apologize, I don't have enough rep to comment on questions. Are you running software to stretch a wallpaper across two displays? Also, which graphics driver are you using? (Intel, AMD, nVidia?) – mikeymop Mar 1 '16 at 15:07
  • No worries, and no I don't believe my wallpaper is stretched. Both monitors have the same picture but it's not stretched between them. Also I believe my graphics driver is nVidia if that helps. – Struggling Mar 1 '16 at 15:25
  • Is there any chance you have tried this? And worst case, trying to replicate your setup on a new user? – mikeymop Mar 1 '16 at 15:31
  • I haven't heard from you, I hope you got this resolved. Best of Luck! – mikeymop Mar 31 '16 at 20:16
0

Well to get my taskbar back I had to move taskbar to another position and then back. The main display loses its taskbar and it becomes an outline. I need background processes which is only on main display.

| improve this answer | |
0

I came across this having a similar problem. Mine was just showing the frame. The suggestion from https://superuser.com/users/549482/mikeymop put me in the right window to fix it for myself.

The "Taskbar location on screen," in Taskbar settings, had changed to custom and changing it back to right (for right side taskbar) made it show properly again.

Screen capture of taskbar location combo box in taskbar settings - Show badges on taskbar buttons - off - taskbar location on screen - right - combine taskbar buttons

| improve this answer | |
0

I have the same problem for over a year and the only solution I've found so far is: * opening the Task Manager (CTRL+SHIFT+ESC), * find and select Windows Explorer, * then click Restart.

This will get your taskbar buttons back (but will also close all opened Explorers).

A better solution...

Toggle the Auto hide of the Taskbar in the Taskbar Settings

| improve this answer | |
  • Just found a better solution ;) – Mathieu Jan 12 at 9:27
  • Toggle the Auto hide of the Taskbar in the Taskbar Settings – Mathieu Jan 12 at 9:27
  • You can edit your answer. – Arjan Jan 12 at 11:53
-2

This could be fixed by updating the Driver.

You can open Device Manager -> Display Adapter, double click on any of the adapter you can see -> go into Driver tag -> choose “Update driver”.

Then you can select “Search automatically for updated driver software”.

This works great for me, hope it works for you as well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.