0

We're developing a site that will be sending emails from noreply@domain.com (this email account doesn't exist) to name@domain.com.

domain.com has emails served via Google Apps; the MX, SPF and DKIM are all set up and marked as passed when testing.

The issue is that no emails sent via our system from noreply@domain.com are going to name@domain.com. Nothing appears in the inbox or the spam, nothing is being delivered at all and I'm banging my head against a brick wall over this issue as I feel I have done everything I can to sort this.

http://www.mail-tester.com/web-7U5MIT - as you'll need some context this is a site I used to test it all.

  • How is your system sending emails? SMTP? PHP mail? – Touff Mar 1 '16 at 17:07
  • I'm at home at the mo but I believe it's PHP Mail – Andy Holmes Mar 1 '16 at 18:59
  • Have you checked the server logs? Is PHP actually sending the e-mail? Have you been able to send that same e-mail to another address outside of that domain? – Touff Mar 1 '16 at 19:20
  • Yeah the email is being sent becuase it comes to my personal gmail absolutely fine. It's definitely something to do with sending and receiving on the same domain – Andy Holmes Mar 1 '16 at 19:39
  • Is your SPF record too limited? By that I mean - does it only allow Google App's servers to send mail, have you allowed the server to send e-mail using your domain as well? You probably would have to add the server's IP to the SPF record. – Touff Mar 1 '16 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.