0

just installed Windows 10 on a seperate HDD on my home computer and ran into problems.

Till yesterday I was able to boot my Fedora system which was the only installed OS, now I installed Windows 10 to another drive and after a restart of the computer it brang up Windows 10 while sda where Fedora is installed was selected as first boot device. I booted up a Fedora LiveCD, reinstalled Grub on sda and was able to boot Fedora again. Grub shows an entry for Windows and after selecting it, it starts the Windows bootloader. But the windows bootloader gave me an error message, that files are missing. After reinstalling the windows bootloader through the Windows installation CD command prompt (bootreq /fixboot und bootreq /fixmbr, only fixboot did not helped), windows is able to start but again no grub...

It is an old pc with a BIOS, no (U)EFI I deactived hibernating in Windows, but it does not seem to help

How to solve this problem?

edit 2.3.16: After reinstalling Grub and booting the Grub Windows entry the error message is as follows: "error: no such device: F2F4A...... Setting partition type to 0x7 Press any key to continue" continue -> "Windows failed to start. A recent hardware or software change might be the cause. To fix the problem insert the windows disc [...]

File: \Boot\BCD Info: The Boot Configuration Data for your PC is missing or contains errors."

  • Can you attach a screenshot of Disk Management in Windows? – Tom Yan Mar 2 '16 at 9:50
  • I will attach it tomorrow Could you tell me what you suspect in the disk management? sda is HDD with three partitions, /boot, one lvm and a ntfs volume sdb is a SSD with the windows boot partition and the main windows partition – GotAQuestion Mar 2 '16 at 18:28
  • Just wanted to see if there's anything weird about the partition schemes that might give a hint on the issue. Btw how exactly do you install grub? – Tom Yan Mar 3 '16 at 2:01
  • booted a live cd, mounted and chrooted in my fedora environment and executed grub2-install /dev/sda screenshot will follow in the evening – GotAQuestion Mar 3 '16 at 14:48
  • You better make sure sdX is really the fedora drive EACH TIME before you run grub2-install /dev/sdX. These namings are not necesarily persistent among boots. – Tom Yan Mar 3 '16 at 15:31
0

Finally solved it!

sda got three partitions, sda1 is /boot from fedora, sda2 is a lvm partition with root and /home on it. sda3 is a ntfs share volume for using it in fedora and windows. sdb is only windows. sda is used as primary boot option. windows installed the executable bootloader files on the ntfs volume on sda3, but the configuration and all other windows files on sdb. grub detected a windows installation on sdb and tried to boot from there, but some files were missing because they were installed on sda3. Just changed the ID of the drive in my grub.conf to the ID from sda3 and it worked!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.