6

In IE 11 on Win 10 when you View Source by doing Ctrl+U, it opens Developer Tools in a pane below the page, which is not what I want. How do I make it open the source in a new window like it always used to do.

  • I have Win 10 and am able to view source in a separate window via either the context menu or Ctrl + u because I have a custom HTML viewer defined in HKLM\SOFTWARE\WOW6432Node\Microsoft\Internet Explorer\View Source Editor\Editor Name. The (Default) value should be set to whatever you want to open the file. Mine is set to C:\Program Files (x86)\Notepad++\nppIExplorerShell.exe because during installation of N++ I checked the option to use it as the default HTML viewer. – Starson Hochschild Mar 3 '16 at 1:21
  • I just want to use the IE source editor. I don't want to set a default editor in the registry. – CJ7 Mar 3 '16 at 1:26
  • 1
    I'm not sure that's possible anymore. – Starson Hochschild Mar 3 '16 at 1:45
1

Simply unpin it (CTRL + P) and it'll open in new window. This switch acts as a toggle. Launch IE View Source Editor (Dev Tools) In A Separate Window In Windows 10

| improve this answer | |
1

This may not be exactly what you are hoping for, but this solution works for me. It took me less than 10 minutes to follow the steps in the blog:

https://en.code-bude.net/2015/11/08/how-to-change-view-source-editor-in-internet-explorer-and-edge/

This blog article walks you through the steps to make the View Source work with an editor of your choosing. I followed the steps and now when I use the context menu (right-click) or even use Ctrl + U to View Source what I get is a plain text document inside of Sublime 3. If you want you can make it open the source html in any editor of your choice.

Steps to Change View Source Editor:

  1. Run dialogue (Win + R) and the command “regedit”.
  2. Find the following Key: Computer\HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer.
  3. Create new Key called View Source Editor.
  4. Create a new Key called Editor Name as a child of View Source Editor.
  5. In the right hand pane of the Registry Editor, double-click the (Default) Key and change the Value Data to match the path to your editor of choice:

enter image description here

| improve this answer | |
  • I am tempted to consider this spam for the blog, since it doesn't contain the steps to solve the problem, within the body of the answer. – Ramhound Jan 4 '18 at 20:04
  • My apologies. I will append the steps right now. I just didn't want to steal credit from the original author. Please let the answer stand for 10 minutes while I update. – Aaron Jan 4 '18 at 20:07
  • So just quote and cite the author. A straight up copy and paste won't be well received either. Of course, you might want to read the question and make sure before you go the effort of improving your answer, that the steps you performed accomplish what the author wanted. I have my doubts, that blog article, explains how to accomplish what the author wanted. – Ramhound Jan 4 '18 at 20:10
  • I have rewritten the steps for brevity and included my own screenshot as an aid. – Aaron Jan 4 '18 at 20:16
0

How do I make it open the source in a new window like it always used to do?

Right click in the window and select "View source"

enter image description here

enter image description here

Note:

  • If I use Ctrl+U I get the source in a separate window (and the Developer Tools does not open ...)
| improve this answer | |
  • 1
    Are you using IE 11 in Win 10? – CJ7 Mar 2 '16 at 23:02
  • Windows 7 64 bit ... – DavidPostill Mar 2 '16 at 23:06
  • Ok, I am using Win 10, so that might be what is causing it. Do you have access to a Win 10 machine to try it out? – CJ7 Mar 2 '16 at 23:20
  • @CJ7 Unfortunately not. Does the right click not work for you? – DavidPostill Mar 2 '16 at 23:20
  • It has the same result as doing Ctrl-U – CJ7 Mar 2 '16 at 23:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.