2

I'm not so familiar with virtualization. I could use it without problems on windows 7/8. Recently i want to use VirtualBox on my new Windows 10 laptop to try out a server: Kaa. They offer a sandbox environment. So i started with it.

I have managed to install Ubuntu 14.04 (the host of the server) as guest OS on my VM. But i am not able to connect with it from my host laptop. I know from the past that you have to set up a bridged adapter, that allows the VM to be connected to the internet AND being communicated from host. (well i hope so).

Problem: the host cannot communicate to VM. And VM cannot communicate to host either !

So far i have already visited the following questions

So far, they all recommend to use either "bridged networking" or "host only". But both doesn't provide result. The problem still persists.

Here below are two images, one showing the network config and other one showing the topology of my laptop

image 1 - network setting of VM

image 2 - noob topology design of network

The VirtualBox version is here below

5.0.14 r105127

(that means the latest one) The IP of the host and VM is the following

PS C:\Users\foo> ipconfig

Windows IP Configuration


Ethernet adapter Ethernet:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Wireless LAN adapter Local Area Connection* 2:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :

Ethernet adapter VirtualBox Host-Only Network:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::1490:45a1:b9cd:3790%3
   IPv4 Address. . . . . . . . . . . : 192.168.56.1
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . :

Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::5cef:ef4f:6ab4:37a4%7
   IPv4 Address. . . . . . . . . . . : 192.168.1.42
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

And the eth0 interface of my VM

kaa@kaa-sandbox.kaaproject.org:/$ ifconfig eth0 | grep addr
eth0    Link encap:Ethernet HWaddr 08:00:27:a0:10:f0
        inet addr:192.168.0.112  Bcast:192.168.0.255  Mask:255.255.255.0
        inet6 addr: fe80::a00:27ff:fea0:10f0/64 Scope:Link

PING test from the host to VM :

PS C:\Users\foo> ping 192.168.0.112

Pinging 192.168.0.112 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for 192.168.0.112:
    Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),
PS C:\Users\foo> tracert -h 10 -w 1000 -4 192.168.0.112

Tracing route to 192.168.0.112 over a maximum of 10 hops

  1     5 ms     1 ms     1 ms  192.168.1.1
  2     *        *        *     Request timed out.
  3     *        *        *     Request timed out.
  4     *        *        *     Request timed out.
  5  PS C:\Users\foo>
PS C:\Users\foo>

PING test from VM to the host :

kaa@kaa-sandbox.kaaproject.org:/$ ping -c 4 192.168.1.42
PING 192.168.1.42 (192.168.1.42) 56(84) bytes of data.
From 192.168.1.42 icmp_seq=1 Destionation Net Unreachable
From 192.168.1.42 icmp_seq=2 Destionation Net Unreachable
From 192.168.1.42 icmp_seq=3 Destionation Net Unreachable
From 192.168.1.42 icmp_seq=4 Destionation Net Unreachable

--- 192.168.1.42 ping statistics ---
4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3004ms

Although it's worth to mention that the VM is in a different subnet. Is that the expected behavior of "bridged adapter" ?

I suspect that the problem doesn't lie at the VM but at how the network is set up ? I do have networking knowledge, but only basic. And since i don't understand how the virtual adapter works, i don't see directly a clue where the problem is.

Or is the problem at Windows 10 itself ?

Maybe someone can point me to the problem and provide a solution ? That would be appreciated.

  • The lack of communication between host and guest is surely due to their lying in disjoint subnets. You should post the output of ip route show on the Ubuntu guest. Also: 1. Does your network use a MAC filter? 2. Does it use VLANs? Do you have a guest network? – MariusMatutiae Mar 2 '16 at 15:22
  • Also, perform this experiment: sudo service network-manager stop; sudo ip link set dev eth0 down; sudo ip addr flush dev eth0; sudo ip link set dev eth0 up; sudo ip addr add 192.168.1.217/24 dev eth0 ; ping -c1 192.168.1.42. Do you get a reply? Please make sure that the host is connected via ethernet, and that, under Network, you have chosen: Name: eth0 (or ethernet, or anything similar to eth). – MariusMatutiae Mar 2 '16 at 15:25
1

What about NAT? If you have servers both on the host and the guest machines, you can even do port forwarding under Settings > Network > Advanced

  • 1
    Yes, what you say is correct (it also works), but the "bridged adapter" option should work too. But i'm not sure if the problem lies at the setup or at the host OS. – KarelG Mar 2 '16 at 13:52
0

Although it's worth to mention that the VM is in a different subnet. Is that the expected behavior of "bridged adapter" ?

If the VM and the hosts have IP configuration in different subnets, then you need a router to allow them to communicate with each other.

a bridged adapter act like a network switch, not a router.

Consider putting the VM and the host in the same subnet, at least temporary to confirm that they can communicate together.

Also check windows firewall, it may block the communication.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.