2

First: I know IE 6 is long dead but I'm using it in a Windows 98 SE virtual machine. This VM is for archival purpose where I archive old Web browsers to share for nostalgia sake. This VM sole reason is to run IE 6.0 SP1.

In this Windows 98 SE machine Internet Explorer 6.0.2800.1106 SP1 always gives The page cannot be displayed when I browse to http://www.google.com/. I have the same issue when browsing to any HTTPS page.

Take note that on the same VM:

  • IE 5.5 (prior IE 6 installation) works well with Google
  • Firefox 2 works with Google and HTTPS
  • Opera 10 works with Google and HTTPS
  • IE 6 SP3 (on a separate Windows XP VM) works with Google HTTPS

Why Google work with IE 5.5, IE 6 SP3 but don't work with IE 6 SP1?

Update: At first I thought the problem was HTTPS page and now I see that HTTPS can't work in IE 6 but I now updated the answer to be more specific (Google don't work).

  • 3
    Because IE 6 SP1 does not support the applicable SSL/TLS versions that the webservers you are accessing support. Firefox 2 and Opera 10 do support the appliciable SSL/TLS versions used by the webserver. – Ramhound Mar 2 '16 at 19:11
  • Internet Explorer relies on Windows crypto APIs for SSL/TLS support. As such, its ability to support newer TLS versions is limited. The most significant effect of this is with IE8: TLS 1.2 does not work on IE8 under XP, but it does work under Windows 7. – bwDraco Mar 2 '16 at 19:29
  • It’s very unlikely IE 5.5 would work when 6.0 doesn’t. – Daniel B Mar 2 '16 at 19:31
  • @Ramhound I just tested right now and TLS 1.0 is enabled and it still don't work, Trust me I tried to fix this for hours searching everywhere before posting my question. I don't have the "diagnose connexion" tool in my error page. – AlexV Mar 2 '16 at 19:37
3

Go to Internet Options (either from Control Panel or from IE's Tools menu) and then to the Advanced tab. Scroll down to the Security section, and make sure that TLS 1.0 is enabled; according to @kobaltz's answer, it's disabled by default. While TLS 1.0 is still outdated, the vast majority of web servers still support it. SSL 2.0 (completely broken) and 3.0 (breakable) are both deprecated, and are the only "secure" protocols IE6 supports by default, but TLS 1.0 will probably stick around for a few more years.

Note that this may still not work with some servers. IE6 doesn't understand some fields of modern X.509 certificates (the things that identify HTTPS servers, and provide the server's public key), so you may get certificate errors from some servers. Also, just because IE6 supports TLS1.0 (once you enable it) doesn't mean it will support all the cipher suites used in TLS 1.0; if it doesn't, then you'll find some servers still might not work.

| improve this answer | |
  • Does 5.5 still work, or did it simply work within the last year or two? The wave of vulns in older protocols have led most server admins to turn off SSL 3.0 over the last few years, so a lot of legacy browsers that used to work will recently have stopped working. – CBHacking Mar 2 '16 at 19:33
  • Also, you should probably mention things that you've already tried (like enabling TLS 1.0, checking specific sites that you know work in other old IE versions, etc.) – CBHacking Mar 2 '16 at 19:35
3

IE 6.0 SP1 can't work with HTTPS nowadays (but IE 6.0 SP3 can).

In the end the problem is on Google side. They seems to redirect to the HTTPS site based on which browser the user use. It seems they can't (or don't) differentiates IE 6.0 SP1 from SP3 and always redirect to the HTTPS site. They don't do that with IE 5.5 (which works because it's not redirected to the HTTPS site).

| improve this answer | |
2

It is mainly about the certificates issued for the sites with HTTPS and the server providing the content. On top of that, IE6 can only support TLS 1.0 (and was disabled by default), and we’re two iterations on from that now. I cannot think of a way that you can browse HTTPS sites using IE6 on Win 98SE.

IEChart

Source: https://en.wikipedia.org/wiki/Template:TLS/SSL_support_history_of_web_browsers

| improve this answer | |
1

No, there is not a way to turn HTTPS back on in a copy of IE that old.

The browser itself does not speak the same encryption language as nearly any modern web server. See the chart found here: https://en.wikipedia.org/wiki/Transport_Layer_Security#Web_browsers

The Windows 98 version of IE6 is different than the version installed with XP and does not know how to handle SHA-2 certificates. That's where most of the web server world is right now. Add to that the inability to speak any other encryption beyond SSL2 and SSL3 and it's no wonder your fifteen year old browser cannot keep up any longer.

Opera and Firefox will give you better handling of more modern encryption as they have had rolling updates to handle some of the changes. Internet Explorer had no such mechanism until much later.

| improve this answer | |
  • Given the differences in the crypto APIs between Windows XP and Windows 98, the Windows 98 version of IE6 is different than the version installed with XP is not the explanation for this behavior. – bwDraco Mar 2 '16 at 20:26
  • but the second half of that sentence is. "and does not know how to handle SHA-2 certificates" sums it up pretty nicely. – jc_ryan Mar 2 '16 at 20:38
1

I know this is an old question but I thought I might mention how I fixed this on Windows 98 (as I couldn't find IE 6 Service Pack 3 for Windows 98). First launch regedit then navigate to [HKEY_LOCAL_MACINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent] and create a new string called "Version" (without the quotes), double click it and enter "MSIE 5.5" (again without the quotes). Then relaunch Internet Explorer, this changes your user agent to Internet Explorer 5.5. Additionally you can also add a string called "Patform" to change which platform websites think you're on. You can also try and changing your post platform by navigating to [HKEY_LOCAL_MACINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\5.0\User Agent\Post Platform] and creating a new string called "SV1", and changing your version vector by navigating to [HKEY_LOCAL_MACINE\SOFTWARE\Microsoft\Internet Explorer\Version Vector] in creating a new string called "IE" and inputting "6.0000" or "5.5000"

| improve this answer | |
  • This was the only actual answer that fixed my issue. Well done and thank you good sir! – Vlad Jan 11 '19 at 7:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.