I am using a 13" Macbook Air 2014 with a 1.7Ghz Intel Core i7 (Intel HD 5000 Graphics). WebGL support seems to be disabled in the latest version of Firefox. Running the simple code snippet

document.createElement('canvas').getContext('webgl')

throws Error: WebGL: Error during native OpenGL init. WebGL works fine in latest Chrome and about:support shows these messages in the "Graphics" section:

about:support

My settings according to about:config:

about:config

What is the reason for WebGL not working properly? What is that dubios previous crash or how can I find out? How do I re-enable it?

  • Try changing the default to specifically false. This also could simply be a bug in Firefox 44, try previous versions, see if those work. – Ramhound Mar 2 '16 at 19:22
  • I can't "set it explicitly" unfortunately. Double clicking leads to "user set: true" and toggling again to the very same default, which is false. This changes nothing in the observed behavior. – heyarne Mar 2 '16 at 20:05
  • After you try a previous version of Firefox. Try creating a new user profile for Firefox. – Ramhound Mar 2 '16 at 20:06
  • How should I go about downgrading Firefox when it automatically installs the current versions? I already tried starting it with Addons disabled which did not help. I also tried the Reset Firefox feature, which unfortunately also did not help. – heyarne Mar 2 '16 at 20:14
  • Have you tried a new user profile? You disable automatic updates, for the profile, before you run the previous version of Firefox or just decline the update. – Ramhound Mar 2 '16 at 20:25

As you can see in the about:support page, GL has been disabled due to a previous crash on the Graphics stack. In order to prevent for more crashes, Firefox disabled WebGL, which is not very nice.

In order to re-enable it, you can simply reset the gfx.crash-guard.status.glcontext value in about:config.

An alternative is to clear the whole profile, but in this way you will lose all your personal settings and thus is not recommended.

  • Thanks! In my case I had to reset gfx.blacklist.webgl.opengl. – bennedich Jul 9 '16 at 20:43

The final solution came from the Mozilla Support Forums, specifically this post:

Try to delete possible user.js and numbered prefs-##.js files and rename/remove the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.

You can use this button to go to the current Firefox profile folder:

Help > Troubleshooting Information > Profile Directory; Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

  • So the solution is to throw the baby out with the bath water? Great! – Sukima Mar 7 '16 at 4:02
  • Yes, unfortunately so. I have not found another way to re-enable the the GLContext, nor could I found out what this previous crash was exactly. – heyarne Mar 8 '16 at 10:50
  • As infuriating as it is the only way for me to get it back also was the destroy every profile I had. I can not understand how that helps the firefox community. – Sukima Mar 8 '16 at 11:54

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.