0

DEAR FUTURE PEOPLE: When this happens, try adding --prefix=/usr/ or --prefix/usr/bin/ to the end of the command to invoke the config script.

I thought that the entire point of including a configuration script was to ensure that things to be installed get installed in the right places, but maybe I'm wrong.

I'm trying to install a program from source (specifically, the new openSSL). The program seems to install fine, but whenever I type "openssl version -a" it gives me the old version. Most annoyingly, whenever I update through my repo (which is still using 1.0.1f, AKA the Heartbleed version, for some bizarre reason).

It's not just openSSL, a couple of other programs do this too, but sometimes it works fine.

How can I force "make install" to always update my symlinks to the new version? If this is not possible, how do I know which symlinks I need to manually update?

Note: I'm new to the whole Unix/Linux thing. And this website. If I've forgotten to include useful troubleshooting information or have a fundamental misunderstanding of how something works, please let me know.

My steps:

Download tarball through Firefox, use File Roller extract to ~/Downloads

Right click extracted folder, open in Terminal

./config

make (I ran it without sudo the first and second time and it worked, but when I tried to run it a thirs time to create the log file it gave permission errors so I ran i through sudo)

make depend (I don't usually do this, but the console told me to)

sudo make install

Note that for privacy reasons, I have replaced all instances of my user name with $LOGNAME.

Logs are in a .zip folder in this Mediafire link. [link removed by question author]

0

It took me 5 days to figure out, but it turns out that the config script for openSSL is borked and it installs to the wrong place. I'm not sure where exactly it's been installing, but it's not the right place.

This can be fixed by running ./config --prefix=/usr/, then redoing make and make install. The --prefix flag will change the install location to whatever you put after the equals sign.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.