72

Since a recent update in Chrome (Windows, desktop) if I change to some tabs, which haven't been opened for a longer time, Chrome automatically performs a refresh on the page. It only happens, when the tab hasn't been opened for a longer time.

It's really disturbing for me, and haven't found any solution to disable this. Anyone knows, how to disable this?

Thanks!

2
  • This could possibly be the wepage itself refreshing after you have been on it for some time to get site visits. Check this Extension Here and it wil disable that feature for websites that do what you are mentioning. Mar 3 '16 at 8:00
  • 2
    It's definitely not the reason, because it happens to all the sites - even to those, which I developed, and I didn't add there such a feature for sure. I'll check out the extension though, if there's no legacy solution, thanks.
    – clementino
    Mar 3 '16 at 8:25
97

The OP is right. This has started happening in the latest release (Chrome Stable Version 48). I was also going bonkers due to this new 'feature' and then I did some research. It is not due to any extension as another user has suggested. It's a relatively new parameter which has been turned ON by default in the new release. Chrome Team is calling it "Tab Discarding". This may happen if there are many Tabs open and Chrome is running out of Memory. According to their documentation, "Tabs are now sorted from most interesting to least interesting. The least interesting tab may be discarded if we run out of physical memory." I suppose least interesting would translate to those tabs which weren't accessed in a while.

Though they are trying to help us free some RAM, however, this 'feature' totally ruins the tab if you don't want its contents to refresh due to some reason, like a YouTube video you paused at a particular location. Or wanted to go back to some top headlines on the homepage of CNN, which you had glanced at earlier and now you want to go back to them, but as soon as you click the tab, this 'feature' auto refreshes the page, updating the headlines. List goes on and on. I also had some Amazon tabs open and had specifically wanted not to have the page update, because it had some particular images and design elements displayed that I wanted to refer later, but when I got back to those pages, the 'Tab-discarding' feature 'auto refreshed' all of them, replacing them with the current version of the pages, totally devoid of whatever I wanted to refer to. And for those who suggest it is probably Amazon's auto-refresh, no, Amazon doesn't auto-refresh product pages, I have had pages remain open for many days and they would never update unless I clicked Refresh.

Now, let's get back to the Solution

To see the 'Discarded Tabs', type this in the Address Bar: chrome://discards/

To actually disable:, type in your address bar: chrome://flags, then disable this flag: #automatic-tab-discarding (Turn it to 'Disabled' from 'Default')

Simple solution to a highly unproductive and frustrating issue. That's it. You can stop pulling your hair out now :)

Source: Google Product Forums

Chrome 63+

In more recent versions of Chrome the #automatic-tab-discarding flag is removed, however, you can still toggle auto discard for chrome desktop apps on the chrome://discards/ page.

12
  • This does work (though be careful on machines with lower resources, your disk might start swapping and your whole system start going more slowly if you turn it off...). Oddly, though, if you do a fresh restart of chrome, it seems to "not load" many of the tabs, so this doesn't seem to fix all of this behavior...I did mention the new tab issue on this bug report, you can vote for it: bugs.chromium.org/p/chromium/issues/detail?id=595240
    – rogerdpack
    Mar 24 '16 at 4:01
  • that's insanely frustraging 'feature' indeed. I did some css and html tricks to the webpage I'm working on, after 60 mins of lunch break all of that has GONE. Brilliant, Chrome.
    – Roman
    Nov 23 '16 at 13:21
  • 1
    Kudos for finding this flag, but history shows that flags in chrome are experimental and using them is just a temporary fix, as any flag may or may not be there in the next version. I would like some html meta tag to say that this page should not be auto-refreshed (and then by implication not discarded either). I would also like a proper user setting, but as a web-developer I prefer to serve hints to less advanced users.
    – Superole
    Feb 10 '17 at 12:39
  • 2
    In the Chrome 67+ the #automatic-tab-discarding flag is back. Which is good, as they discard old tabs even more aggressively now, I believe. P.S. Great answer. Thank you!
    – Dime
    Jul 12 '18 at 7:31
  • 1
    Seems like in Chrome 78 all the previous tab-discarding flags disappeared, and it's turned on again after the update. Any ideas, how to disable it again?
    – clementino
    Jan 7 '20 at 14:09
1

I think it's called this now:

Proactive Tab Freeze and Discard

Enables proactive tab freezing and discarding. This requires #enable-page-almost-idle. – Mac, Windows, Linux, Chrome OS

#proactive-tab-freeze-and-discard

0

Give this a try.

Chrome

Step 1 Click the wrench icon in the top right corner, then click on "Tools" and then "Extensions."

Step 2 Scroll to the bottom of the screen and click on "Get more extensions."

Step 3 Type "Stop AutoRefresh" into the search box and press "Enter" on your keyboard.

Step 4 Click on "Add to Chrome" next to the result for "Stop AutoRefresh," which should be the first result.

Step 5 Click "Add" on the confirmation screen.

Step 6 Click on the extension icon (a white circular arrow in a red hexagon) at the top of the screen when you want to stop a page automatically refreshing. Note that the icon only appears when you visit a page that uses automatic refreshing.

Information pulled from How to Stop Web Pages From Constantly Updating

3
0

Chrome is prerendering tabs/sites, if you were not in this tab for a long time or while you typing an URL and chrome "thinks" that you "were so often before on it, that this should be the target URL"

You can disable this in chrome://settings/advanced by turning off Predict network actions to improve page load performance

This was also explained in Can I turn off Google Chrome's new prerendering?

1
  • "chrome://settings/advanced" just keeps us in the settings page
    – killjoy
    Apr 6 '17 at 11:36
0

The direct path (as of 20190130) to disable this abomination labeled as a "feature" is now:

chrome://flags/#automatic-tab-discarding
1
  • Unfortunately this doesn't seem to prevent new tabs which haven't been focused yet from loading until they are focused. This threw me off because I thought disabling the flag didn't work at first. For me this is equally annoying and I haven't found a fix yet. Feb 18 '19 at 10:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.