2

My Enigmail is constantly prompting for password when clicking on emails that have already been decrypted a second ago, switching between encrypted emails that have been decrypted.

In the Enigmail preferences, it's set to remember the passphrase for 20 minutes but it doesn't.

When I go into Enigmail preferences and click OK without changing anything, I get the following message:

Cannot connect to gpg-agent. Maybe your system uses a specialized tool for passphrase handling (e.g. gnome-keyring, seahorse-agent, KDE wallet manager, ...). Unfortunately Enigmail cannot control the passphrase timeout for the tool you are using. Therefore the respective timeout settings in Enigmail are disregarded.

Below is the output of my gpg-agent.conf:

  $ cat .gnupg/gpg-agent.conf 
    default-cache-ttl 1200
    max-cache-ttl 99999

Can anyone help? This is very annoying.

  • "Maybe your system uses a specialized tool for passphrase handling (e.g. gnome-keyring, seahorse-agent, KDE wallet manager, ...)." -- are you using any of those? They act as gpg-agent , but do not completely implement its API, thus issues like this occur. If you use any of them (have installed any of them is probably enough), have a look at how to disable GnuPG-integration for those. – Jens Erat Mar 3 '16 at 14:08
  • @JensErat I tried disabling it from autostarting as in this answer. Logged out and logged in but the problem persists. The only one of the listed applications I found installed was gnome-keyring. – Proletariat Mar 3 '16 at 14:29
1

I fixed it by following these instructions by enigmail.net:

Check the contents of $HOME/.gnupg/gpg-agent.conf. Make sure that there is a configuration entry pinentry-program containing the full path to a graphical version of pinentry as above. E.g.:

pinentry-program /usr/local/bin/pinentry-gtk

Then save the file.

Add the following line to your $HOME/.gnupg/gpg.conf file:

use-agent

Then save the file and restart your PC.

I am on Ubuntu 14.04.4 LTS.

  • Note that it may be the case that you need to use pinentry-program /usr/bin/pinentry-gtk-2 or pinentry-program /usr/bin/pinentry-qt instead of pinentry-program /usr/local/bin/pinentry-gtk. – Clément Mar 29 '17 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.