1

I have an internal secondary SATA HDD in my Laptop, Windows 8.1 constantly spins it down.

I already set "turn off hard disk after" to never in power options.

I booted debian and turned off stand by using hdparm.

But still, the HDD keeps spinning down, a problem already known in Win 8.1.

Do you have other tips on how to prevent this? I would like to keep this HDD spinning constantly.

internal SATA HDD, 1 TB, Western Digital (not USB drive)

  • FWIW, ATA drive settings (APM, standby timeout, write cache...) are volatile among power cycles (at least for all the drives I've ever used), so you need to look for a program in Windows which sets those for you and make it run on every boot (and you probably need to run it after suspend as well...) – Tom Yan Mar 4 '16 at 7:36
  • The only exception I've seen is a WD My Passport. The reason its standby timeout setting is persistent among power cycles is because the state is stored in the "enclosure" and it reinforce the setting on the ATA drive behind upon power up every time. – Tom Yan Mar 4 '16 at 7:42
  • This might help, tho it didn't help me : ( superuser.com/questions/236815/… – B T Jan 4 '17 at 22:22
0

I tried a WD DOS program, but this did not change anything. I am using KeepAlive HD now, it creates a text file on defined HDDs even in seconds interval.

Idiotic, but works. for me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.