3

I basically never want to use the feature. How to? There's another question here that answers how to disable it in Linux via a command-line option in .bashrc, but I don't think that can be done in Windows?

Edit: Additional information:

  • I am on Windows 10

  • No Recovery.xcu anywhere on my C drive.

  • even if I discard recovery data, then the next time I open the same file there is no recovery prompt. But when I shutdown Windows without shutting down LibreOffice first, then I get the prompt the next time I open the file.

3

Can I prevent LibreOffice from prompting for document recovery?

when it launches or I open a file?

To disable when launching a LibreOffice program

Start LibreOffice with the --norestore command line option:

  1. Right click on the "LibreOffice" Writer start menu entry.

    enter image description here

  2. Click "Properties".

    enter image description here

  3. Add --norestore to the end of the "Target" entry.

  4. Click "OK".

  5. Repeat steps 1-4 for each of the programs in the LibreOffice suite.

To disable when opening a file

Uncheck the "Save AutoRecovery information every:" option:

  1. Start "LibreOffice".

  2. Menu "Tools" > "Options".

  3. Expand "Load/Save".

  4. Select "General".

  5. Uncheck "Save AutoRecovery information every:".

    enter image description here

  6. Click OK.

  7. Close "LibreOffice".

Now you can open files.

5
  • Sorry, I forgot to mention, I've already disabled that Autorecovery checkbox in the options, I still get prompted with autorecovery info
    – Roy Tang
    Mar 5 '16 at 17:27
  • Search C:\Users\<username>\AppData and subdirectories for Recovery.xcu. Delete it and try again.
    – DavidPostill
    Mar 5 '16 at 17:41
  • No such file anywhere on my C drive. I'm on Windows 10 if that matters. BTW, it's happening to me even if I discard recovery data, then the next time I open the same file there is no recovery prompt. But when I shutdown Windows without shutting down LibreOffice first, then I get the prompt the next time I open the file.
    – Roy Tang
    Mar 6 '16 at 23:05
  • Then don't shutdown without closing LibreOffice!
    – DavidPostill
    Mar 6 '16 at 23:10
  • Unchecking the "Save AutoRecovery information every:" doesn't prevent the dialog on next launch after crash.
    – Ruslan
    Jan 26 '20 at 8:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.